给定一个长度不超过 104 的、仅由英文字母构成的字符串。请将字符重新调整顺序,按 PATestPATest....
这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。
输入格式:
输入在一行中给出一个长度不超过 104 的、仅由英文字母构成的非空字符串。
输出格式:
在一行中按题目要求输出排序后的字符串。题目保证输出非空。
输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee
解题思路:
#include <stdio.h>
#define MAXN 10024
int main(int argc, const char *argv[])
{
char str[MAXN], c;
int i=0, n=0, sum=0, pat[7]={0};
if ( scanf("%s", str)==EOF ) printf("error\n");
do {
c = str[i++];
n = (c=='P')*1 + (c=='A')*2 + (c=='T')*3 + (c=='e')*4 + (c=='s')*5 + (c=='t')*6;
pat[n]++;
if ( n ) sum++;
} while ( str[i]!=0 );
while ( sum ) {
for ( i=1; i<7; i++ ) {
if ( pat[i]>0 ) {
switch ( i ) {
case 1: printf("P"); break;
case 2: printf("A"); break;
case 3: printf("T"); break;
case 4: printf("e"); break;
case 5: printf("s"); break;
case 6: printf("t"); break;
}
pat[i]--;
sum--;
}
}
}
return 0;
}