hdu 4497 (gcd和lcm的性质+排列组合)

GCD and LCM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Problem Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L?
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z.
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.
 

Input
First line comes an integer T (T <= 12), telling the number of test cases.
The next T lines, each contains two positive 32-bit signed integers, G and L.
It’s guaranteed that each answer will fit in a 32-bit signed integer.
 

Output
For each test case, print one line with the number of solutions satisfying the conditions above.
 

Sample Input
  
  
2 6 72 7 33
 

Sample Output
  
  
72 0
解题思路:已知x%g=y%g=z%g=0,l%x=l%y=l%z=0,所以l%g=0。这个可以判定是否存在(x,y,z)符合条件。
把K = L/G质数分解,L / G = p1^t1 * p2^t2 * p3^t3 * ……;同时 x/= G, y/= G, z/=G,不影响结果。
假设将x,y,z分解质因数后:
x = p1^i1 * p2^i2 * p3^i3 *......
y = p1^j1 * p2^j2 * p3^j3 *......
z = p1^k1 * p2^k2 * p3^k3 *......
此时,x,y,z互质,lcm(x,y,z) = K,那么对于p1来说,i1,j1,k1中必定有一个数为t1,有一个数为0,另外一个数可以从0-t1任意。

0 0 t1          有3种

t1 t1 0         有3种

t1 0 1~t1-1  有(t1-1)*6种

一共是6*t1种。

总数可以利用乘法原理:6t1*6t2*......

这道题正好发现了我的一个错误结论:lcm = x*y*z / gcd;

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
	int t,num[1010],cnt,m,n,ans;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		if(m % n != 0)
		{
			printf("0\n");
			continue;
		}
		m = m / n;
		cnt = 0;
		for(int i = 2; i * i <= m; i++)
		{
			if(m % i == 0)
			{
				num[cnt] = 0;
				while(m % i == 0)
				{
					m = m / i;
					num[cnt]++;
				}
				cnt++;
			}
		}
		if(m != 1) num[cnt++] = 1;
		ans = 1;
		for(int i = 0; i < cnt; i++) ans = ans * num[i] * 6;
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值