hdu 5056(尺取法)

Boring count

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
 

Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
 

Output
For each case, output a line contains the answer.
 

Sample Input
  
  
3 abc 1 abcabc 1 abcabc 2
 

Sample Output
  
  
6 15 21
 
题目大意:就是问在子串中每个小写字母出现次数不超过k次的个数
解题思路:尺取法,维护i和j使得str[i]到str[j]之间的所有小写字母的个数不超过k。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 100005;
int k,len,cnt[200];
char str[maxn];

bool check()
{
	for(char i = 'a'; i <= 'z'; i++)
		if(cnt[i] > k) return false;
	return true;
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(cnt,0,sizeof(cnt));
		cin >> str >> k;
		len = strlen(str);
		__int64 ans = 0;
		for(int i = 0, j = 0; i < len; i++)
		{
			cnt[str[i]]++;
			while(check() == false) 
			{
				cnt[str[j]]--;
				j++;
			}
			ans += i - j + 1;
		}
		printf("%I64d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值