poj 2258 The Settlers of Catan(边的搜索)

The Settlers of Catan
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1193 Accepted: 782

Description

Within Settlers of Catan, the 1995 German game of the year, players attempt to dominate an island by building roads, settlements and cities across its uncharted wilderness. 
You are employed by a software company that just has decided to develop a computer version of this game, and you are chosen to implement one of the game's special rules: 

When the game ends, the player who built the longest road gains two extra victory points. 
The problem here is that the players usually build complex road networks and not just one linear path. Therefore, determining the longest road is not trivial (although human players usually see it immediately). 
Compared to the original game, we will solve a simplified problem here: You are given a set of nodes (cities) and a set of edges (road segments) of length 1 connecting the nodes. 
The longest road is defined as the longest path within the network that doesn't use an edge twice. Nodes may be visited more than once, though. 

Example: The following network contains a road of length 12. 
o      o--o      o

 \    /    \    /

  o--o      o--o

 /    \    /    \

o      o--o      o--o

           \    /

            o--o

Input

The input will contain one or more test cases. 
The first line of each test case contains two integers: the number of nodes n (2<=n<=25) and the number of edges m (1<=m<=25). The next m lines describe the m edges. Each edge is given by the numbers of the two nodes connected by it. Nodes are numbered from 0 to n-1. Edges are undirected. Nodes have degrees of three or less. The network is not neccessarily connected. 
Input will be terminated by two values of 0 for n and m.

Output

For each test case, print the length of the longest road on a single line.

Sample Input

3 2
0 1
1 2
15 16
0 2
1 2
2 3
3 4
3 5
4 6
5 7
6 8
7 8
7 9
8 10
9 11
10 12
11 12
10 13
12 14
0 0

Sample Output

2

12

这个题目让求的是图的所有路径中最长的路径,可以用深度遍历来解决,注意:其中结点可以重复遍历,而边不可以重复遍历。所以应当在深度遍历上做一定修改,将对结点的遍历改为对边的遍历。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 30;
int n,m,ans;
int map[maxn][maxn];
int select[maxn][maxn];

void dfs(int u,int len)
{
	ans = max(ans,len);
	for(int i = 0; i < n; i++)
	{
		if(map[u][i] == 0 || select[u][i] == 1) continue;
		select[u][i] = select[i][u] = 1;
		dfs(i,len + 1);
		select[u][i] = select[i][u] = 0;
	}
}

int main()
{
	int u,v;
	while(scanf("%d%d",&n,&m),n+m)
	{
		memset(map,0,sizeof(map));
		for(int i = 1; i <= m; i++)
		{
			scanf("%d%d",&u,&v);
			map[u][v] = map[v][u] = 1;
		}
		ans = 0;
		for(int i = 0; i < n; i++)
		{
			memset(select,0,sizeof(select));
			dfs(i,0);
		}
		printf("%d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值