poj 3255 Roadblocks

Roadblocks
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 11409 Accepted: 4028

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input

Line 1: Two space-separated integers:  N and  R 
Lines 2.. R+1: Each line contains three space-separated integers:  AB, and  D that describe a road that connects intersections  A and  B and has length  D (1 ≤  D ≤ 5000)

Output

Line 1: The length of the second shortest path between node 1 and node  N

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

Source




dij 次短路


//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<string>
#include<sstream>
#include<cstdlib>
#include<cstring>
#include<cctype>
#include<algorithm>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<deque>
#include<cmath>
#include<climits>
#include<list>
#include<utility>
#include<memory>
#include<cstddef>
#include<iterator>
#include<iomanip>

using namespace std;
typedef long long LL;
typedef long double LD;
const double PI = acos(-1.0);
///

const int MAX_N = 5005;
typedef pair<int, int> P;
const int INF = 999999;

struct edge {
	int to;
	int cost;
	
};

int N, R;
vector<edge> G[MAX_N];

int dist[MAX_N];
int dist2[MAX_N];

void swap(int &a, int &b) {
	int temp = a;
	a = b;
	b = temp;
}

void solve() {
	priority_queue < P, vector<P>, greater<P> >que;
	fill(dist, dist + N, INF);
	fill(dist2, dist2 + N, INF);

	dist[0] = 0;
	que.push(P(0, 0));

	while (!que.empty()) {
		P p = que.top(); que.pop();
		int v = p.second;
		int d = p.first;
		for (int i = 0; i < G[v].size(); i++) {
			edge &e = G[v][i];
			int d2 = d + e.cost;
			if (dist[e.to] > d2) {
				swap(dist[e.to], d2);
				que.push(P(dist[e.to], e.to));
			}
			if (dist2[e.to] > d2&&dist[e.to] < d2) {
				dist2[e.to] = d2;
				que.push(P(dist2[e.to], e.to));
			}
		}

	}
	cout << dist2[N - 1] << endl;

}






///
int main(int argc, char**argv) {
	ios_base::sync_with_stdio(0); cin.tie(0);
	//freopen("input.txt", "r", stdin);、
	//freopen("output.txt", "w", stdout);
	

	cin >> N >> R;

	for (int i = 0; i < R; i++) {
		int a, b, c;
		cin >> a >> b >> c;
		edge w;
		w.to = b-1;
		w.cost = c;
		edge ww;
		ww.to=a-1;
		ww.cost=c;
		G[b-1].push_back(ww);
		G[a-1].push_back(w);
	}
	

	solve();





	
	//system("pause");
	return 0;
}

//END





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值