余数 UVA 408

背景:

Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form :

seed(x + 1) = [seed(x) + STEP]%MOD

where “%” is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD−1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD − 1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD − 1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x + 1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD − 1, it will generate pseudo-random numbers uniformly with every MOD iterations. If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD − 1. Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.

Input

Each line of input will contain a pair of integers for STEP and MOD in that order (1 ≤ STEP, MOD ≤100000).

Output

For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either ‘Good Choice’ or ‘Bad Choice’ left-justified starting in column 25. The ‘Good Choice’ message should be printed when the selection of ST EP and MOD will generate all the numbers between and including 0 and MOD − 1 when MOD numbers are generated. Otherwise, your program should print the message ‘Bad Choice’. After each output test set, your program should print exactly one blank line.

Sample Input

3 5
15 20
63923 99999

Sample Output

3 5 Good Choice
15 20 Bad Choice
63923 99999 Good Choice

题意:seed(0)是一个任意值(当然我们在写程序时,可以赋0,不影响输出),给出STEP和MOD问是否可以生成全部的[0,MOD-1]的序列。

解法1:转变成找 循环 的题目,需要两层循环。若在前MOD(次)时,未出现相同的余数,则是Good Choice。否则Bad。

解法2:把题目转化成 :
若是Bad,则STEP 与MOD必有公约数(即非素数)。
若是Good,则STEP 与MOD必互素。

理解:(非严格推导,主要因为博主不会)
(以下MOD简写成M,STEP为ST)

seed(x+1) = (seed(x)+ST)%M
 = (seed(x) % M + ST % M)%M [^1]
 = { [ seed(x-1)%M +ST%M]%M+ ST%M } % M 
 = [seed(x-1)  + (ST+ST) }%M [^2]
 = [seed(x-1)  + 2*ST }%M 
 = ... = (seed(0) + (x+1)*ST )%M

1.(eg.  2%5=2  4%5=4  (2+4)%5=1 <=>(2%5+4%5=1)
2.(这一步把大括号里的所有的M都删去,里面无论取余不取余,都不影响最后的值,博主未严格证明)

如果不能生成全部序列一定存在 0 <= j,i < MOD 使得生成值相同( i-j != M ),即

   seed(i) = (seed(0) + ST*i)%M
   seed(j) = (seed(0) + ST*j)%M
   两式相减
   因为两式seed(i)=seed(j)
   根据余数含义可知
   (seed(0) + ST*i)-(seed(0) + ST*j)=ST*(i-j)=nM;(因为i!=j,所以n!=0)
    (相同余数的两个被除数之差等于除数的倍数)
    因为n不确定且n!=0(在满足情况下),i-j为正整数,所以此时
    M/(ST/n)=(i-j)   i-j <M
    ST/n 必是M的因子。即gcd( STEP,MOD ) ≠ 1

由此可知,可以生成全部序列的充要条件是 gcd( STEP,MOD ) = 1,即互素。(可能可以由反证可得,博主已经想不动了)

代码(小白菜又菜)1

#include <iostream>
#include <cstdlib>
#include <cstdio>
 
using namespace std;
 
int gcd( int a, int b )
{
	return a%b?gcd(b,a%b):b;
}
 
int main()
{
	int a,b;
	while ( ~scanf("%d%d",&a,&b) ) {
		printf("%10d%10d",a,b);
		if ( gcd( a, b ) == 1 )
			printf("    Good Choice\n");
		else printf("    Bad Choice\n");
		printf("\n");
	}
	return 0;
}

总结:

1.和余数有关的题,很多都很奇妙。多举一些例子,观察 输入 的数之间的 关系。 一般可以猜出规律。但这必须很敏感。
2.这种题的不同做法真tm显智商,博主深感智商不足。

参考资料


  1. https://blog.csdn.net/mobius_strip/article/details/32318773
    (若侵则删,此文博主:小白菜又菜) ↩︎

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值