HDU-1014 Uniform Generator

                                  Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32580    Accepted Submission(s): 12979
Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where '%' is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
Sample Input
3 5
15 20
63923 99999
Sample Output
 
  
         3         5    Good Choice        15        20    Bad Choice     63923     99999    Good Choice
题目大意:给出两个变量step和mod,从i=0开始,求step*i%mod,直到出现循环。问0~mod-1中的每个数,在循环中出现的次数是否相等,题目不难,甚至很水,直接模拟能过,但是有更好的写法。

解法一:直接模拟

#include<bits/stdc++.h>
using namespace std;

int a[100005];
int main()
{
    int i,step,mod,ans;
    while(cin>>step>>mod)
    {
        memset(a,0,sizeof(a));
        ans=0;
        a[0]++;
        while(true)
        {
            ans=(ans+step)%mod;
            if(ans!=0)
               a[ans]++;
            else
                break;
        }
        sort(a,a+mod);
        printf("%10d%10d    ",step,mod);
        if(a[0]!=a[mod-1])
        {
            printf("Bad Choice\n\n");
        }
        else
        {
            printf("Good Choice\n\n");
        }
    }
}

解法二:(1)若gcd(step,mod)!=1,则step*i%mod=k*gcd(step,mod),0~mod-1每一个数不可能取到;
            (2)若gcd(step,mod)==1;seek(0)==0,最小公倍数=step*mod,seek(mod)==0;所以seek(x)以mod为一个循环,若step和mod满足条件,则循环中每个数有且仅出现一次;

证明:若对于gcd(step,mod)==1,若存在有1个数字出现多次,第一次位置为i,第二次在位置j;则该序列以j-i为一个循环,又j-i<mod,与之前推出结论矛盾,所以不存在有一个数字出现多次,所以当gcd(step,mod)==1输出 Good Choice;否则输出 Bad Choice;
#include<bits/stdc++.h>
using namespace std;

int gcd(int n,int m)
{
    if(m==0)
        return n;
    else return gcd(m,n%m);
}
int main()
{
    int step,mod;
    while(cin>>step>>mod)
    {
        int ans=gcd(step,mod);
        if(ans==1)
            cout<<setw(10)<<step<<setw(10)<<mod<<"    "<<"Good Choice"<<endl;
        else
            cout<<setw(10)<<step<<setw(10)<<mod<<"    "<<"Bad Choice"<<endl;
        cout<<endl;
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值