Problem Description
A ring is composeof n circles as shown in diagram. Put natural number 1, 2, ..., n into eachcircle separately, and the sum of numbers in two adjacent circles should be aprime.
Note: the number of first circle should always be 1.
Input
n (0 < n <20).
Output
The output formatis shown as sample below. Each row represents a series of circle numbers in thering beginning from 1 clockwisely and anticlockwisely. The order of numbersmust satisfy the above requirements. Print solutions in lexicographical order.
You are to write a program that completes above process.
Print a blank line after each case.
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2
#include<iostream>
using namespace std;int cnt=1;
int n;
int vis[21],a[21];
int comp(int n)
{
int i,flag=1;
for (i=2;i<=sqrt(n);i++)
if (n%i==0) {flag=0;break;}
if (flag==1) return 1; else return 0;
}
void dfs(int cur)
{
if(cur==n&&comp(a[0]+a[n-1]))
{
cout<<a[0];
for(int i=1;i<n;i++)
{
cout<<" "<<a[i];
}
cout<<endl;
}
else for(int i=2;i<=n;i++)
{
if(vis[i]==0&&comp(i+a[cur-1]))
{
a[cur]=i;
vis[i]=1;
dfs(cur+1);
vis[i]=0;
}
}
}
int main()
{
a[0]=1;
while(cin>>n)
{
memset(vis,0,sizeof(vis));
cout << "Case " << cnt++ <<":"<<endl;
dfs(1);
cout<<endl;
}
return 0;
}