杭电OJ题 1016 Prime Ring Problem解题报告

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16431    Accepted Submission(s): 7471


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

————————————————————————————————————————
简单的深搜题

/****************************
 *Name:Prime Ring Problem.c
 *Tags:ACM DFS search
 ****************************/

#include <stdio.h>
#include <math.h>

int prime(int );
void DFS(int *, int);
int flag[20], t;

int main()
{
      int n, i, count = 0;
      int num[20];
      while(scanf("%d", &n) != EOF) {
	    for(i = 0; i < n; i++) {
		  flag[i] = 1;
	    }
	    flag[0] = 0;
	    t = 0;
	    count++;
	    printf("Case %d:\n", count);
	    num[t++] = 1;
	    DFS(num, n);
	    printf("\n");
      }
      return 0;
}

int prime(int i)
{
      int j;
      for(j = 2; j <= sqrt(i); j++) {
	    if(i % j == 0) {
		  return 0;
	    }
      }
      return 1;
}

void DFS(int *num, int n)
{
      int i, sum;
      if(t == n) {
	    if(prime(num[t-1]+num[0])) {
		  printf("%d", num[0]);
		  for(i = 1; i < t; i++) {
			printf(" %d", num[i]);
		  }
		  printf("\n");
	    }
      } else {
	    for(i = 1; i < n; i++) {
		  if(flag[i] && prime(i+1+num[t-1])) {
			num[t++] = i+1;
			flag[i] = 0;
			DFS(num, n);
			--t;
			flag[i] = 1;
		  }
	    }
      }
}		  


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值