贪心百练oj1328

1328:Radar Installation

总时间限制:
1000ms
内存限制:
65536kB
描述
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations
输入
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
输出
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.
样例输入
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
样例输出
Case 1: 2
Case 2: 1
图片是我个人理解的简述,看懂了以后,下面就是代码了:(因为如果找不到一个比第一组最小右端点大的左端点的话需要一颗雷达,所以雷达数目初始化为1)

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
struct pos
{
    double x;  //因为一开始思路出现了一点小小的问题,所以姑且认为这两个结构体等价就行了
    double y;
}position[1005];//记录小岛的横纵坐标结构体,其实没必要这样,需要两个变量就够了
struct posi
{
    double x;
    double y;
}coor[1005];//记录小岛在x轴上投影的结构体 x为断点,y为右端点
int n,m;
bool cmp(struct posi r1, struct posi r2)
{
    return r1.x<r2.x;
}            //对投影区间进行排序
int greedyheart()//贪心算法关键部分
{    
     int x;
    int num=0;
    int len=0;
    int count=1;
     double temp = coor[0].y;           //先给一组区间右端点最小值赋予初值  
        for(int j = 1; j < n; j++)      
        {   
            if(coor[j].y < temp)   //不断更新区间右端点最小值
                temp = coor[j].y;  
            else if(coor[j].x > temp)  
            {                                      //如果有左端点超过右端点,雷达数就加1
                count++;  
                temp = coor[j].y;  
            }  
        }  
    return count;//返回雷达数
}
int main()
{
    int flag=0;
    int test=0;
    int number;  
    while(scanf("%d%d",&n,&m))
    {
        flag=0;
        number=0;
        if(n==0&&m==0)
          break;
        for(int i=0;i<n;++i)
        {
           cin>>position[i].x>>position[i].y;
          coor[i].x=position[i].x-sqrt(1.0*(m*m-position[i].y*position[i].y));
          coor[i].y=position[i].x+sqrt(1.0*(m*m-position[i].y*position[i].y));   //将岛的横纵坐标反映到x轴上的区间
          if(position[i].y>m)
          {
              flag=1;    //此种情况必然无解,不解释
          }
        }
        if(flag)
        {
            printf("Case %d: -1\n",++test);  //无解就这样做
            continue;
        }
        sort(coor,coor+n,cmp);  //对投影区间按照左端点从小到大排序
        printf("Case %d: %d\n",++test,greedyheart());
     
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值