贪心算法-(百练)1083:Moving Tables

描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.

输出
The output should contain the minimum time in minutes to complete the moving, one per line.

样例输入
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

样例输出
10
20
30

题意:
两侧房间搬桌子,搬运过程有冲突就不能同时搬运,求最长时间
(搬运1次10分钟)
解题思路:
1、每一次移动一个桌子会经过南北两侧的房间,所以除以2只需要计算一侧的就行,统计重叠的次数,重叠次数最多*10就是所需要的最长时间
2、桌子可以从1号房间移动到10号房间,也可以从10号房间移动到1号房间,需要交换一下x,y值
3、注意起点和终点的对门也要被占用

Code:

#include<iostream>
#include<algorithm>
#include<numeric>
#include<vector>
using namespace std;
int a[105];
int main(){
	int T;
	cin>>T;
	while(T--){
		fill(a,a+205,0);//统计经过的次数 
		int N;
		cin>>N;
		while(N--){
			int x,y;
			cin>>x>>y;
			if(x>y)
				swap(x,y);//防止从10号房间搬到1号房间 
			x=(x+1)/2,y=(y+1)/2;//分为南北两个  经过两个其实是一趟 所以除以2即可 
			for(int i=x;i<=y;i++)
				++a[i];
		} 
		cout<<((*max_element(a,a+205))*10)<<endl;//找出重叠次数最大的 
	} 
	return 0;
} 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值