寒假集训第二天 贪心 add all


10954 Add All Yup!! The problem name reflects your task; just add a set of numbers. But you may feel yourselves condescended, to write a C/C++ program just to add a set of numbers. Such a problem will simply question your erudition. So, lets add some flavor of ingenuity to it. Addition operation requires cost now, and the cost is the summation of those two to be added. So, to add 1 and 10, you need a cost of 11. If you want to add 1, 2 and 3. There are several ways 1 + 2 = 3, cost = 3 1 + 3 = 4, cost = 4 2 + 3 = 5, cost = 5 3 + 3 = 6, cost = 6 2 + 4 = 6, cost = 6 1 + 5 = 6, cost = 6 Total = 9 Total = 10 Total = 11

Input Each test case will start with a positive number, N (2 ≤ N ≤ 5000) followed by N positive integers (all are less than 100000). I nput is terminated by a case where the value of N is zero. This case should not be processed.

Output For each case print the minimum total cost of addition in a single line.

Sample Input 3 1 2 3 4 1 2 3 4 0

Sample Output 9 19
题意:一个集合的整数,将其中两个数相加,结果为花销。然后花销加入到整数集合中,求最后花销为多少?
贪心策略:每次找到集合中最小的两个数相加 

代码:
/*

推荐题型:三星,使用两个数组存储数据方便找到最小值

贪心,一次AC

题意:一个集合的整数,将其中两个数相加,结果为花销。然后花销加入到整数集合中,求最后花销为多少?

贪心策略:每次找到集合中最小的两个数相加
*/

#include <cstdio>
#include <cstdlib>
const int nMax=5007;
int A[nMax],a_pos;
int B[nMax],b_front,b_rear;
int N;
int cmp(const void *a,const void *b)
{
	int *pa=(int *)a;
	int *pb=(int *)b;
	return *pa-*pb;
}
void get_min(int &a)
{
	if(b_front==b_rear)//B中无元素
	{
		a=A[a_pos++];
	}
	else if(a_pos == N)//A中无元素
	{
		a=B[b_front++];
	}
	else
	{
		if(A[a_pos]<B[b_front])
			a=A[a_pos++];
		else
			a=B[b_front++];
	}
}
int main()
{
	//freopen("f://data.in","r",stdin);
	while(scanf("%d",&N) && N)
	{
		int i;
		for(i = 0; i < N; i ++)
			scanf("%d", & A[i]);
		qsort(A,N,sizeof(A[0]),cmp);
		a_pos=0;
		b_front=b_rear=0;
		for(i = 0; i < N - 1; i ++)
		{
			int a,b;
			get_min(a);
			get_min(b);
			B[b_rear++] = a + b;
		}
		int sum=0;
		for(i = 0;i < N - 1; i ++)
			sum+=B[i];
		printf("%d\n",sum);
	}
	return 0;
}
#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<cstring>
//#include<bits/stdc++.h>
using namespace std;
#define N 5010
bool cmp(int a,int b)
{
    return a<b;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(1)
    {
        int n;
        scanf("%d",&n);
        if(n==0)
            break;
        int num[N];
        memset(num,0,sizeof(num));
        for(int i= 0; i<n; i++)
            scanf("%d",num+i);
        int sum=0;
        for(int i=0;i<n-1;i++)
        {
            sort(num+i,num+n,cmp);
            sum=sum+num[i]+num[i+1];
            num[i+1]=num[i]+num[i+1];
        }
        printf("%d\n",sum);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值