HDOJ 2105 The Center of Gravity(超级水题)

The Center of Gravity

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5708    Accepted Submission(s): 3285


Problem Description
Everyone know the story that how Newton discovered the Universal Gravitation. One day, Newton walked
leisurely, suddenly, an apple hit his head. Then Newton discovered the Universal Gravitation.From then
on,people have sovled many problems by the the theory of the Universal Gravitation. What's more, wo also
have known every object has its Center of Gravity.
Now,you have been given the coordinates of three points of a triangle. Can you calculate the center
of gravity of the triangle?
 

Input
The first line is an integer n,which is the number of test cases.
Then n lines follow. Each line has 6 numbers x1,y1,x2,y2,x3,y3,which are the coordinates of three points.
The input is terminated by n = 0.
 

Output
For each case, print the coordinate, accurate up to 1 decimal places.
 

Sample Input
  
  
2 1.0 2.0 3.0 4.0 5.0 2.0 1.0 1.0 4.0 1.0 1.0 5.0 0
 

Sample Output
  
  
3.0 2.7 2.0 2.3
 

Source


思路:%.f有自带四舍五入功能

代码:
#include<cstdio>
#include<iostream>
using namespace std;

int main() 
{
	int num;
	while(cin>>num&&num)
	{
		for(int i=0;i<num;i++)
		{
			double x1,x2,x3,y1,y2,y3;
			cin>>x1>>y1>>x2>>y2>>x3>>y3;
			double x=(x1+x2+x3)/3.0;
			double y=(y1+y2+y3)/3.0;
			printf("%.1f %.1f\n",x,y);//printf格式自带四舍五入 
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值