A hard puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 40613 Accepted Submission(s): 14632
Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
7 66 8 800
Sample Output
9 6
Author
eddy
思路:
题意就是给你两个数a.b,让你求a的b次方的个位数的值。根据打表可以发现是有规律的,所以直接枚举了。
代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int aa,bb;
while(cin>>aa>>bb)
{
int a=aa%10;
int b1=bb%4;
int b2=bb%2;
if(bb==0)
{
cout<<"1"<<endl;
continue;
}
if(a==1)cout<<"1"<<endl;
else if(a==2)
{
if(b1==1)cout<<"2"<<endl;
if(b1==2)cout<<"4"<<endl;
if(b1==3)cout<<"8"<<endl;
if(b1==0)cout<<"6"<<endl;
}
else if(a==3)
{
if(b1==1)cout<<"3"<<endl;
if(b1==2)cout<<"9"<<endl;
if(b1==3)cout<<"7"<<endl;
if(b1==0)cout<<"1"<<endl;
}
else if(a==4)
{
if(b2%2==1)cout<<"4"<<endl;
else cout<<"6"<<endl;
}
else if(a==5||a==6)cout<<a<<endl;
else if(a==7)
{
if(b1==1)cout<<"7"<<endl;
if(b1==2)cout<<"9"<<endl;
if(b1==3)cout<<"3"<<endl;
if(b1==0)cout<<"1"<<endl;
}
else if(a==8)
{
if(b1==1)cout<<"8"<<endl;
if(b1==2)cout<<"4"<<endl;
if(b1==3)cout<<"2"<<endl;
if(b1==0)cout<<"6"<<endl;
}
else if(a==9)
{
if(b2%2==1)cout<<"9"<<endl;
else cout<<"1"<<endl;
}
else if(a==0)cout<<"0"<<endl;
}
return 0;
}