PAT甲级-- 1034 Head of a Gang (30 分)

One way that the police finds the head of a gang is to check people's phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A "Gang" is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from A-Z. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

思路:

1. 总的来说,这是一道图的遍历问题,用到DFS深搜

2. 存储编号与name之间的对应关系用map,还要存储首领的名字到团伙成员数量的映射关系

3. 对每一个连通块,要记录最大权值的点即head,还要记录用的边权

4. 当深搜完一个连通块时,要判断成员数是否大于2个,大于两个成为团伙

#include <iostream>
#include <vector>
#include <string>
#include <set>
#include <map>
#include <algorithm>
using namespace std;

const int MAXN = 2010;
map<string,int> name2num;
map<int,string> num2name;
map<string, int> Gang;

int G[MAXN][MAXN] = {0};
bool visit[MAXN] = {false};
int n, k, weight[MAXN] = {0}; //weight是每个点总权重
int numPerson = 0;

void dfs(int nowVisit, int& head, int& numMember, int& totalValue)
{
	numMember++; //成员数+1
	visit[nowVisit] = true; //标记已访问
	if (weight[nowVisit] > weight[head])  //该店的权重比当前头目权重大,更新头目
	{
		head = nowVisit;
	}

	for (int i = 0; i < numPerson; i++) //枚举每个人
	{
		if (G[nowVisit][i] > 0)  //从当前点能到达i
		{
			totalValue += G[nowVisit][i];  //总边权增加
			G[nowVisit][i] = G[i][nowVisit] = 0; //删除这条边,防止回头
			if (visit[i] == false) //递归访问i
			{
				dfs(i, head, numMember, totalValue);
			}
		}
	}
}

int change(string str)  //在映射中查找,若找到则返回其编号,找不到新分配编号
{
	if(name2num.find(str) != name2num.end())
	{
		return name2num[str];
	}else
	{
		name2num[str] = numPerson;
		num2name[numPerson] = str;
		return numPerson++;
	}
}



int main() 
{
	scanf("%d%d",&n, &k);
	for (int i = 0; i < n; i++)
	{
		string n1, n2;
		int len;
		cin >> n1 >> n2 >> len;
		int id1 = change(n1);
		int id2 = change(n2);
		weight[id1] += len;
		weight[id2] += len;
		G[id1][id2] += len;
		G[id2][id1] += len;
	}

	for (int i = 0; i < numPerson; i++)  //枚举所有人
	{
		if (visit[i] == false)  //如果i未访问
		{
			int head = i, numMember = 0, totalValue = 0;  //头目、团伙成员,总的边权
			dfs(i, head, numMember, totalValue);
			if (numMember > 2 && totalValue > k)//团伙成员数大于2并且总边权大于给定的值
			{
				Gang[num2name[head]] = numMember; //进行映射
			}
		}
	}

	cout << Gang.size() << endl;
	for (auto it = Gang.begin(); it != Gang.end(); it++)
	{
		cout << it->first << " " << it->second << endl;
	}

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值