PAT甲级 -- 1068 Find More Coins (30 分)

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she must pay the exact amount. Since she has as many as 10​4​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find some coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​4​​, the total number of coins) and M (≤10​2​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the face values V​1​​≤V​2​​≤⋯≤V​k​​ such that V​1​​+V​2​​+⋯+V​k​​=M. All the numbers must be separated by a space, and there must be no extra space at the end of the line. If such a solution is not unique, output the smallest sequence. If there is no solution, output "No Solution" instead.

Note: sequence {A[1], A[2], ...} is said to be "smaller" than sequence {B[1], B[2], ...} if there exists k≥1 such that A[i]=B[i] for all i<k, and A[k] < B[k].

Sample Input 1:

8 9
5 9 8 7 2 3 4 1

Sample Output 1:

1 3 5

Sample Input 2:

4 8
7 2 4 3

Sample Output 2:

No Solution

我的思路:

1. 01背包问题,因为是输出最小的排列,所以考虑先从小到大排序,dp没有思路....去看了柳神的代码

2. 同志仍需努力啊,数学思维还是不到位啊啊!

 

 

柳神:

1. 01背包问题, dp【i】【v】表示前 i 件物品恰好放入容量为v的背包里的最大价值,此题中,最大价值就是币面总额,容量为m

2. 因为要输出最小,和我的思路不一样,柳神是选择按从大到小排...

3. choice【i】【j】记录,在容量为j的情况下,i号有没有被选择,选择为true,没选则为false

4. dp【i】数组记录容量为i的情况下,最大的价值,此题,在容量为m的情况下,最大价值也必须为m,所以可以作为判断依据

5. 从后往前遍历硬币面值,根据choice的选择情况,进行输出。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int n, m;
int dp[10010], choice[10010][10010];
int w[10010];
vector<int> ans;

bool cmp(int a, int b){
	return a > b;
}

int main() {
	scanf("%d%d", &n, &m);
	for(int i = 1; i <= n; i++){
		scanf("%d", &w[i]);
	}
	sort(w+1, w+1+n, cmp);
	for(int i = 1; i <= n; i++){
		for(int v = m; v >= w[i]; v--){
			if(dp[v] <= dp[v-w[i]] + w[i]){
				choice[i][v] = true;
				dp[v] = dp[v-w[i]] + w[i];
			}
		}
	}
	if(dp[m] != m) printf("No Solution");
	else
	{
		int index = n, v = m;
		while (v > 0){
			if(choice[index][v] == true){  //在当前容量下,被选择了,放入ans
				ans.push_back(w[index]);
				v -= w[index];
			}
			index--;
		}

		for(int i = 0; i < ans.size(); i++){
			if(i != 0) printf(" ");
			printf("%d", ans[i]);
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值