PTA 7-228 加法口诀表

该博客展示了如何编写一个C程序来输出指定整数n的加法口诀表,遵循特定的格式要求,如列间距、行末空格等。程序通过双重循环实现,适用于初学者理解控制流和输出格式控制。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

PTA 7-228 加法口诀表

分数 10
作者 李祥
单位 湖北经济学院

请编写程序,输出 n+n 的加法口诀表。

输入格式
n

输出格式
n+n 的加法口诀表。

样例输入

5

样例输出

1+1= 2 2+1= 3 3+1= 4 4+1= 5 5+1= 6
1+2= 3 2+2= 4 3+2= 5 4+2= 6 5+2= 7
1+3= 4 2+3= 5 3+3= 6 4+3= 7 5+3= 8
1+4= 5 2+4= 6 3+4= 7 4+4= 8 5+4= 9
1+5= 6 2+5= 7 3+5= 8 4+5= 9 5+5=10

注:和的域宽2格(右对齐);两列之间空1格;行末没有空格。

代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB

#include <stdio.h>
int main(){
    int integer;
    scanf("%d", &integer);
    for(int i=1; i<=integer; i++){  //每排换行
        for(int j=1; j<=integer; j++){  //每列输出
            if(j == integer){   //是最后输出的个后面没有空格
                printf("%d+%d=%2d", j, i, i+j);
            }else{
                printf("%d+%d=%2d ", j, i, i+j);
            }
        }
        printf("\n");
    }
    return 0;
}
### PTA 7-2 重排链表解法 对于PTA平台上的7-2重排链表题目,可以采用类似于LeetCode第143题的方法来解决这个问题。具体来说,在处理单链表 \(L\) 的时候,目标是将其重新排列成特定模式:\(L_0 \rightarrow L_n \rightarrow L_1 \rightarrow L_{n-1} \rightarrow L_2 \rightarrow L_{n-2}\ldots\)[^3]。 为了实现这一目标,通常会采取以下策略: #### 方法概述 1. **找到中间节点** 首先利用快慢指针技术定位到链表的中间位置。这一步骤有助于后续操作中的效率提升。 2. **反转后半部分链表** 找到中间节点之后,将链表从中点断开并单独对后面的部分执行翻转操作。这样做可以让后面的元素按照相反顺序连接起来。 3. **交替合并两段链表** 接下来就是把前一半未改变顺序的链表同已经反转过的另一半依次交错相连,从而形成最终所需的输出形式。 下面是具体的Python代码实现方式: ```python class ListNode: def __init__(self, val=0, next=None): self.val = val self.next = next def reorderList(head: ListNode) -> None: if not head or not head.next: return # Step 1: Find the middle of the list using slow and fast pointers. slow, fast = head, head while fast and fast.next: slow = slow.next fast = fast.next.next # Step 2: Reverse the second half of the linked list starting from 'slow'. prev, curr = None, slow while curr: temp_next = curr.next curr.next = prev prev = curr curr = temp_next # Now `prev` points to the last element (new start point after reversing). # Step 3: Merge two halves by alternating nodes between them. first_half, second_half = head, prev while second_half.next: tmp_first = first_half.next tmp_second = second_half.next first_half.next = second_half second_half.next = tmp_first first_half = tmp_first second_half = tmp_second ``` 此算法的时间复杂度主要取决于遍历次数以及每次遍历时的操作量级,整体时间复杂度大约为O(n),其中n代表链表长度;空间复杂度则保持在常数级别O(1),因为只用了有限数量额外变量存储临时状态信息。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值