L2-011 玩转二叉树

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
1 2 3 4 5 6 7
4 1 3 2 6 5 7

输出样例:

4 6 1 7 5 3 2

我真是个天才,可以用反转前的层序遍历后的结果再用bfs遍历二叉树时把它的左右节点反转,然后顺便输出,这样就得到了反转后的层序遍历。

code


#include<iostream>
#include<algorithm>
#include<queue>
#include<string>
#include<vector>
#include<cstring>
#include<map>
#include<set>
#include<unordered_set>
#include<stack>
using namespace std;
const int manx = 2e5 + 10;
typedef pair <int, int>PII;
int a[manx];
int b[manx];
vector<int>v[35];
int p[manx];
int l[manx];
int r[manx];
int build(int al, int ar, int bl, int br, int d)
{
    if (al > ar)return 0;
    int val = a[al];
    int k = p[val];//p记录的是当前根节点的位置
    l[val]=build(al+1, al + k - bl, bl, k - 1, d + 1);//层序遍历出的左儿子
    r[val]=build(al + k - bl+1, ar, k + 1, br, d + 1);//右儿子
    return val;
}
int flag = 1;//这个是防止pta恶心卡空格
void bfs()
{
    queue<int>q;
    q.push(a[0]);
    while (q.size())
    {
        int t = q.front();
        if (flag)
        {
            cout << t;
            flag = 0;
        }
        else
        {
            cout <<" "<<t;
        }
        q.pop();
        if (l[t] && r[t])//如果左右儿子都存在就反转
        {
            swap(l[t], r[t]);
            q.push(l[t]);
            q.push(r[t]);
        }
        if (l[t] && !r[t])//只存在其一就说明根节点只有一个儿子,无需反转(不影响层序遍历的结果)直接装进队列
        {
            q.push(l[t]);
        }
        if (!l[t] && r[t])
        {
            q.push(r[t]);
        }
    }
    cout << endl;
}
void solve()
{
    int n;
    cin >> n;
    for (int i = 0; i < n; i++)cin >> b[i];
    for (int i = 0; i < n; i++)cin >> a[i];
    for (int i = 0; i < n; i++)p[b[i]] = i;
    build(0, n - 1, 0, n - 1, 0);
    bfs();
}
int main()
{
    int t;
    ios::sync_with_stdio(false); cin.tie(0); cout.tie(0);
    //cin >> t;
    t = 1;
    while (t--)
    {
        solve();
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值