L2-011. 玩转二叉树

L2-011. 玩转二叉树

给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2

提交代码

给定中序遍历和前序遍历,构造二叉树并且从右往左层序输出

code:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 50;
int in[maxn],pre[maxn];
struct node{
    int l,r;
}tre[maxn];
int build(int la,int ra,int lb,int rb){//la,ra表示中序遍历,lb,rb表示前序遍历
    if(la > ra){
        return 0;
    }
    int rt = pre[lb];//前序遍历第一点为根
    int p1,p2;
    p1 = la;//在中序遍历中找到这个点,分出左右子树
    while(in[p1] != rt) p1++;
    p2 = p1 - la;//左子树点的个数
    tre[rt].l = build(la,p1-1,lb+1,lb+p2);
    tre[rt].r = build(p1+1,ra,lb+p2+1,rb);
    return rt;
}
void bfs(int rt){
    queue<int>q;
    vector<int>v;
    q.push(rt);
    while(!q.empty()){
        int w = q.front();
        q.pop();
        if(w == 0) break;
        v.push_back(w);
        if(tre[w].r != 0)//因为要镜像翻转实际层序遍历从右往左就可以了
            q.push(tre[w].r);
        if(tre[w].l != 0)
            q.push(tre[w].l);
    }
    for(int i = 0; i < v.size(); i++){
        printf("%d%c",v[i],i == v.size()-1 ? '\n' : ' ');
    }
}
int main(){
    int n;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%d",&in[i]);
    }
    for(int i = 0; i < n; i++){
        scanf("%d",&pre[i]);
    }
    int root = build(0,n-1,0,n-1);
    bfs(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值