HOJ1987 Recursive Function

Recursive Function

My Tags  (Edit)
 Source : SCU Programming Contest 2005 Preliminary
 Time limit : 1 sec Memory limit : 32 M

Submitted : 12941, Accepted : 3290

Function f(n) is recursively defined as:

  • f(n) = f(n-1) + f(n-3), n > 3
  • f(n) = n, n <= 3

Write a program to calculate f(n) modulo m.

n <= 10000, 2 <= m <= 10000.

Input

There are multiple test cases. Each test case consists of two integers: n and m. n = 0 and m = 0 denotes the end of input, and you should not process this case.

Output

For each test case, print f(n) modulo m in a single line.

Sample Input

1 2
10000 999
0 0

Sample Output

1
433

Authorwiltord

/*注意n<0的情况*/
#include <iostream>
#include<stdio.h>
using namespace std;
#define MAX 10000
int  a[MAX+1];
int main()
{
    int n,m,i;
    while(cin >> n >> m && (n!=0||m!=0))
    {
        if(n < 0)
        {
            while(n < 0)
            {
                n += m;
            }
           cout << n%m << endl;
        }
        else
        {
            for(i=0; i<=n; i++)
            {
                if(i < 4)   a[i]=i%m;
                else a[i]=(a[i-1]+a[i-3])%m;
            }
           cout << a[n] << endl;
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值