ACM学习-POJ-1017-Packets

菜鸟学习ACM,纪录自己成长过程中的点滴。

学习的路上,与君共勉。

 ACM学习-POJ-1017-Packets

Packets
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40435 Accepted: 13553

Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input

0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0 

Sample Output

2 
1 

Source



问题描述
一个工厂制造的产品形状都是长方体,它们的高度都是 h,长和宽都相等,一共有六个 型号,他们的长宽分别为 1*1, 2*2, 3*3, 4*4, 5*5, 6*6.  这些产品通常使用一个  6*6*h  的长方 体包裹包装然后邮寄给客户。因为邮费很贵,所以工厂要想方设法的减小每个订单运送时的 包裹数量。他们很需要有一个好的程序帮他们解决这个问题从而节省费用。现在这个程序由 你来设计。 
输入数据 
输入文件包括几行,每一行代表一个订单。每个订单里的一行包括六个整数,中间用空 格隔开,分别为 1*1 至 6*6 这六种产品的数量。输入文件将以 6 个 0 组成的一行结尾。 
输出要求 
除了输入的最后一行 6 个 0 以外,输入文件里每一行对应着输出文件的一行,每一行输 出一个整数代表对应的订单所需的最小包裹数。 
输入样例
0 0 4 0 0 1  
7 5 1 0 0 0  
0 0 0 0 0 0  
输出样例 
2  
1  
解题思路
这个问题描述得比较清楚,我们在这里只解释一下输入输出样例:共有两组有效输入,第一组表示有 4 个 3*3 的产品和一个 6*6 的产品,此时 4 个 3*3 的产品占用一个箱子,另外一个 6*6 的产品占用 1 个箱子,所以箱子数是 2;第二组表示有 7 个 1*1 的产品,5 个 2*2的产品和 1 个 3*3 的产品,我们可以把他们统统放在一个箱子中,所以输出是 1。分析六个型号的产品占用箱子的具体情况如下:6*6  的产品每个会占用一个完整的箱子,并且没有空余空间;5*5 的产品每个占用一个新的箱子,并且留下 11 个可以盛放 1*1的产品的空余空间;4*4 的产品每个占用一个新的箱子,并且留下 5 个可以盛放 2*2 的产品的空余空间;3*3 的产品情况比较复杂,首先 3*3 的产品不能放在原来盛有 5*5 或者 4*4 的箱子中,那么必须为 3*3 的产品另开新的箱子,新开的箱子数目等于 3*3 的产品的数目除以4 向上取整;同时我们需要讨论为 3*3 的产品新开箱子时,剩余的空间可以盛放多少 2*2 和1*1 的产品(这里如果有空间可以盛放 2*2 的产品,我们就将它计入 2*2 的空余空间,等到2*2 的产品全部装完,如果还有 2*2 的空间剩余,再将它们转换成 1*1 的剩余空间)。我们可以分情况讨论为 3*3 的产品打开的新箱子中剩余的空位,共为四种情况:第一种,3*3 的产品的数目正好是 4 的倍数,所以没有空余空间;第二种,3*3 的产品数目是 4 的倍数加 1,这时还剩 5 个 2*2 的空位和 7 个 1*1 的空位;第三种,3*3 的产品数目是 4 的倍数加 2,这时还剩 3 个 2*2 的空位和 6 个 1*1 的空位;第四种,3*3 的产品数目是 4 的倍数加 3,这时还剩 1 个 2*2 的空位和 5 个 1*1 的空位;处理完 3*3 的产品,就可以比较一下剩余的 2*2的空位和 2*2 产品的数目,如果产品数目多,就将 2*2 的空位全部填满,再为 2*2 的产品打开新箱子,同时计算新箱子中 1*1 的空位,如果剩余空位多,就将 2*2 的产品全部填入 2*2的空位,再将剩余的 2*2 的空位转换成 1*1 的空位;最后处理 1*1 的产品,比较一下 1*1
的空位与 1*1 的产品数目,如果空位多,将 1*1 的产品全部填入空位,否则,先将 1*1 的空位填满,然后再为 1*1 的产品打开新的箱子。


下面给出AC代码
#include <stdio.h>

int three_two[4] = {0, 5, 3, 1};  //  装有3*3的箱子可放2*2的个数  three_two[1]表示有1个3*3的情况下还可往里放5个2*2
int three_one[4] = {0, 7, 6, 5};  //  装有3*3的箱子在three_two[]对应情况下可以放的1*1的个数
                                  //  如three_one[2] == 6表示在2个3*3的情况下,可以放3个2*2,可以放6个1*1
int main()
{
    int i;
    int box_[7];  //记录每个对应规格产品个数
    int sum_;      //箱子总个数
    int count_1;    //可以放入其他箱子中1*1产品个数
    int count_2;    //可以放入其他箱子中2*2产品个数
    while (1)
    {
        sum_ = 0;     //输入
        for (i=1; i<=6; i++)
        {
            scanf("%d",&box_[i]);
            sum_ += box_[i];
        }
        if (sum_ == 0)      //如果全为0 结束
        {
            break;
        }
        
        sum_ = box_[4] + box_[5] + box_[6] + (box_[3] + 3)/4;  
        count_1 = 11 * box_[5] + three_one[box_[3]%4];  //1*1可放入5*5中和放入3*3中的个数
        count_2 = 5 * box_[4] + three_two[box_[3]%4];   //2*2可放入4*4中和放入3*3中的个数
        
        if (count_2<box_[2])    //如果不够放2*2。 开辟新的箱子
        {
            sum_ += (box_[2] - count_2 + 8) / 9;  //加上新开的箱子个数
            count_1 += 4 * ( 9 * ((box_[2] - count_2 + 8) / 9) - (box_[2] - count_2));//开新箱子剩下的地方装1*1的包 
        }
        else
            count_1 += 4 * (count_2 - box_[2]);
        if (count_1 < box_[1])  //如果不够放1*1。 开辟新的箱子
            sum_ += (box_[1] - count_1 + 35) / 36;
        
        printf("%d\n", sum_);
        
    }
    return 0;
}


评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Colin丶

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值