ZOJ 3939 The Lucky Week 找规律打表

ZOJ Problem Set - 3939
The Lucky Week
Time Limit: 2 Seconds Memory Limit: 65536 KB

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week “The Lucky Week”.

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?
Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward’s query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).
Output

For each case, print the date of the Monday of the N-th Lucky Week.
Sample Input

2
2016 4 11 2
2016 1 11 10

Sample Output

2016 7 11
2017 9 11

分析:
自己做的时候就往循环节上考虑,但是没耐心,到最后都不想做了
这题的解析可以参考这篇:http://blog.csdn.net/zcj5027/article/details/51235656写的很详细。
因为闰年有4年和400年,可以想到400年就可能是一个循环节,把1753年开始的400年的lucky week都找出来,然后大于这些的算一下就好

#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<stack>
using namespace std;
typedef long long ll;
typedef struct point
{
    int year,month,day;
    point(){}
    point(int y,int m,int d):year(y),month(m),day(d){}
};
point a[10000];
int n,cnt;
int d1[]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int d2[]={0,31,29,31,30,31,30,31,31,30,31,30,31};
bool check(int x){
    return (x%400==0||(x%4==0&&x%100!=0));
}
void init()
{
    cnt=1;
    int d=1;
    for(int i=1753;i<=1753+399;i++){
        bool flag=check(i);
        for(int j=1;j<=12;j++){
            int tmp=(flag?d2[j]:d1[j]);
            while(d<=tmp){
                if(d==1||d==11||d==21){
                    a[cnt]=point(i,j,d);
                    cnt++;
                }
                d+=7;
            }
            d-=tmp;
        }
    }
}
int main()
{
    init();
    cnt--;
    int T;scanf("%d",&T);
    while(T--){
        int y,m,d;
        scanf("%d%d%d",&y,&m,&d);
        int n; scanf("%d",&n);
        n--;
        int sum=n/cnt;
        int tmp=n-sum*cnt;
        while(y>=1753+400){
            y-=400;sum++;
        }
        int g;
        for(int i=1;i<=cnt;i++){
            if(y==a[i].year&&m==a[i].month&&d==a[i].day){
                g=i;
                g+=tmp;
                while(g>cnt)g-=cnt,sum++;
                break;
            }
        }
        ll t1=(ll)a[g].year+(ll)sum*400;
        printf("%lld %d %d\n",t1,a[g].month,a[g].day);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值