POJ 2752 Seek the Name, Seek the Fame (kmp next数组运用)

题目链接:点击打开链接

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16855 Accepted: 8583

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father's name and the mother's name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题目大意:给你一串字符串,问哪些前缀跟某个后缀是一样的,输出这个前缀最后一个字符的下标

这个我有纠结一下,后来想明白了,因为后缀必须得以最后一个字符结尾,这样想清楚,就可以利用next数组的一些性质可以明白了,如果不明白,可以自己模拟一下


#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char st[1000100];
int next[1001000];
int num[1001000];
void getnext(char st[],int m)
{
    int j = 0 ,k = -1;
    next[0] = -1;
    while (j < m)
    {
        if (k == -1 || st[j] == st[k] )
        {
            ++j;
            ++k;
            next[j] = k;
        }
        else 
        {
            k = next[k];
        }
        //printf("%d\n",next[j]);
    }
}
int main()
{
    while (~scanf("%s",st))
    {
        int len = strlen(st);
        getnext(st,len);
        int j = 0;
        while (len)
        {
            num[j] = next[len];
            len = next[len];
            j++;
        }
        for (int i = j - 2 ; i >= 0 ; i-- )
        {
            printf("%d ",num[i]);
        }
        printf("%d\n",strlen(st));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值