hdu5763 Another Meaning(kmp+dp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5763

Another Meaning

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 999    Accepted Submission(s): 476



Problem Description
As is known to all, in many cases, a word has two meanings. Such as “hehe”, which not only means “hehe”, but also means “excuse me”.
Today, ?? is chating with MeiZi online, MeiZi sends a sentence A to ??. ?? is so smart that he knows the word B in the sentence has two meanings. He wants to know how many kinds of meanings MeiZi can express.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each test case contains two strings A and B, A means the sentence MeiZi sends to ??, B means the word B which has two menaings. string only contains lowercase letters.

Limits
T <= 30
|A| <= 100000
|B| <= |A|

 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 1000000007.
 

Sample Input
  
  
4 hehehe hehe woquxizaolehehe woquxizaole hehehehe hehe owoadiuhzgneninougur iehiehieh
Sample Output
 
 
Case #1: 3 Case #2: 2 Case #3: 5 Case #4: 1
Hint
In the first case, “ hehehe” can have 3 meaings: “*he”, “he*”, “hehehe”. In the third case, “hehehehe” can have 5 meaings: “*hehe”, “he*he”, “hehe*”, “**”, “hehehehe”.

题目大意:给你两串字符串,问第一串哪些部分可以用第二串字符来代替,问组合起来总共会有多少个

思路:kmp+dp

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
char st[111111],temp[111111];
int num[111111];
int Next[111111];  
long long mod = 1e9 + 7;
int dp[111111];
void getNext()  
{  
    memset(Next,0,sizeof(Next));  
    Next[0]=-1;  
    int j=0;  
    int k=-1;  
    while(temp[j])  
    {  
        if(k == -1 || temp[j] == temp[k])  
        { 
            j++;  
            k++;  
            Next[j] = k;  
        }  
        else   
        {  
            k = Next[k];  
        }  
    }  
}  
int main()
{
    int t;
    scanf("%d",&t);
    for (int cas = 1 ; cas <= t ; cas ++)
    {
        memset(num,0,sizeof(num));
        scanf("%s",st);
        scanf("%s",temp);
        getNext();
        int n = strlen(st);
        int m = strlen(temp);
        dp[0] = 1;
        int j = 0;
        for (int i = 0 ; i < n; i++) 
        {
            while (j && st[i] != temp[j]) 
                j = Next[j];
            if (st[i] == temp[j]) 
                j++;
            dp[i + 1] = dp[i];
            if (j == m) 
            {
                dp[i + 1] = (dp[i + 1] + dp[i - m + 1]) % mod;
                j = Next[j];
            }
        }
        printf("Case #%d: %lld\n",cas,dp[n]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值