hdu1576 A/B

题目要求
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
输入

数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

输出
对应每组数据输出(A/B)%9973。

样例输入

2
1000 53
87 123456789

样例输出

7922
6060

数论水题。
欧拉定理求逆元,因为平方过大所以要对9973取余。

因为 由于 ,
故 ax=1(mod m)
故 (b/a)mod m
===>(b*x)mod m
===>(b%m * x%m)%m
n=(A%9973);
ans=(A/B)%9973==>(A*b)%9973(b为B的逆元)==>(A%9973*b%9973)%9973==>(n*b%9973)%9973;
求出B的逆元即可。

实现代码:

#include<stdio.h>
#include<algorithm>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<queue>
#include<stack>
#include<cstring>
#include<vector>
#define inf 0x3f3f3f3f
#define N 100000+10
#define LL long long
#define odd 1000000007
using namespace std;
int gcd(int a,int b)
{
    int mod;
    while(b)
    {
        mod=a%b;
        a=b;b=mod;
    }
    return a;
}
LL ksm(LL a,LL b)
{
    LL ans=1,base=a;
    while(b)
    {
        if(b&1!=0)
            ans=(base*ans)%9973;
        base=(base*base)%9973;
        b>>=1;
    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        LL n,b,x,sum=0;
        scanf("%lld%lld",&n,&b);
        for(int i=1;i<=9972;i++)
            if(gcd(9973,i)==1)
                sum++;
        LL ans=((n)*(ksm(b,sum-1)%9973))%9973;
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值