HDU-1247 Hat’s Words (Trie 字典树)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16368    Accepted Submission(s): 5835


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 
#include <bits/stdc++.h>
using namespace std;
int ch[500000][26], st[50002 * 26 * 20], tot; //st[i] == 1表示结点i是某个单词的结尾
string s[50005];
void insert(string s){
	int k = 0, y;
	for(int i = 0; i < s.size(); ++i){
		y = s[i] - 'a';
		if(ch[k][y] == 0){
			ch[k][y] = ++tot;
		}
		k = ch[k][y];
	}
	st[k] = 1;
}
bool check(string s, int pos){
	int k = 0, y;
	for(int i = pos; i < s.size(); ++i){
		y = s[i] - 'a';
		if(ch[k][y] == 0) return false;
		k = ch[k][y];
	}
	if(st[k]) return true;
	return false;
}
bool query(string s){
	int k = 0, y;
	for(int i = 0; i < s.size(); ++i){
		y = s[i] - 'a';
		if(ch[k][y] == 0){
			return false;
		}
		k = ch[k][y];
		if(st[k] == 1){
			if(check(s, i + 1)){
				return true;
			}
		}
	}
	return false;
}
int main(){
	int x = 1;
	tot = 0;
	while(cin>>s[x]){
		insert(s[x]);
		x++;
	}
	for(int i = 1; i < x; ++i){
		if(query(s[i])){
			cout<<s[i]<<endl;
		}
	}
}

/*
题意:一共50000个单词,问哪些单词可以由其余单词中的两个拼接而成。
比如hmc可以由hm和c拼接成。单词长度没说。。。

思路:trie的小应用,对所有的单词建trie,然后在这棵trie上枚举所有
单词,当遇到st值为1时再判断接下来的部分是否是一个完整的单词即可。

这个方法很容易想到,应该可以被优化,欢迎指点。。。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值