POJ-2184 Cow Exhibition (带负坐标的01背包 坐标平移)

Cow Exhibition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14198 Accepted: 5763

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

Hint

OUTPUT DETAILS: 

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF 
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value 
of TS+TF to 10, but the new value of TF would be negative, so it is not 
allowed. 


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[200002], s[101], f[101];
int main(){
    int n;
    scanf("%d", &n);
    for(int i = 1; i <= n; ++i){
        scanf("%d %d", &s[i], &f[i]);
    }
    for(int i = 0; i <= 100000 + 1000 * n; ++i){
        dp[i] = -1e9;
    }
    dp[100000] = 0;
    for(int i = 1; i <= n; ++i){
        if(s[i] <= 0 && f[i] <= 0) continue;
        if(s[i] < 0){
            for(int j = 0; j <= 100000 + 1000 * n + s[i]; ++j){
                dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
            }
        }
        else{
            for(int j = 100000 + 1000 * n; j >= s[i]; --j){
                dp[j] = max(dp[j], dp[j - s[i]] + f[i]);
            }
        }
    }
    int ans = -1e9;
    for(int i = 100000; i <= 100000 + 1000 * n; ++i){
        if(dp[i] >= 0){
            ans = max(ans, dp[i] + i - 100000);
        }
    }
    printf("%d\n", ans);
}

/*
题意:有100头牛,每头牛有一个智力值和幽默值,值的范围是-1000~1000,从中选一些牛,使得智力值的和和
幽默值的和非负,并让两者的和最大。

思路:其实可以想到用dp[i]表示智力值为i时最大可以有多少幽默值,但是i可能为负,这就尴尬了。那么我们
不妨将坐标系整体平移100 * 1000,这样所有的取法都不可能是负的。这样0~100*1000之间就是原本为负的值的
情况。然后注意一下转移就好了。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值