POJ-1947 Rebuilding Roads (树上背包)

Rebuilding Roads
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 12245 Accepted: 5673

Description

The cows have reconstructed Farmer John's farm, with its N barns (1 <= N <= 150, number 1..N) after the terrible earthquake last May. The cows didn't have time to rebuild any extra roads, so now there is exactly one way to get from any given barn to any other barn. Thus, the farm transportation system can be represented as a tree. 

Farmer John wants to know how much damage another earthquake could do. He wants to know the minimum number of roads whose destruction would isolate a subtree of exactly P (1 <= P <= N) barns from the rest of the barns.

Input

* Line 1: Two integers, N and P 

* Lines 2..N: N-1 lines, each with two integers I and J. Node I is node J's parent in the tree of roads. 

Output

A single line containing the integer that is the minimum number of roads that need to be destroyed for a subtree of P nodes to be isolated. 

Sample Input

11 6
1 2
1 3
1 4
1 5
2 6
2 7
2 8
4 9
4 10
4 11

Sample Output

2

#include <stdio.h>
#include <vector>
#include <string.h>
using namespace std;
vector<vector<int> > g(151);
int dp[151][151], pre[151], n, p;
void dfs(int x){
	for(int i = 0; i <= p; ++i){
		dp[x][i] = 1e9;
	}
	dp[x][1] = 0;  //叶子节点,不包括父亲节点,不需要切就可得1个
	int cur;
	for(int i = 0; i < g[x].size(); ++i){
		cur = g[x][i];
		dfs(cur);
		for(int j = p; j >= 0; --j){ 
			dp[x][j] += 1;   //不包括当前儿子
			for(int s = 1; s < j; ++s){  //包括当前儿子
				dp[x][j] = min(dp[x][j], dp[x][j - s] + dp[cur][s]);
			}
		}
	}
}
int main(){
	int u, v;
	scanf("%d %d", &n, &p);
	memset(pre, 0, sizeof(pre));
	for(int i = 1; i < n; ++i){
		scanf("%d %d", &u, &v);
		g[u].push_back(v);
		pre[v] = u;
	}
	int rt;
	for(int i = 1; i <= n; ++i){
		if(pre[i] == 0){
			rt = i;
			break;
		}
	}
	dfs(rt);
	int ans = dp[rt][p];
	for(int i = 1; i <= n; ++i){
		ans = min(ans, dp[i][p] + 1);
	}
	printf("%d\n", ans);
}

/*
题意:
一棵树,150个节点,现在想得到一棵有p个节点的子树,问最少需要切多少边才可以得到。

思路:
树上背包,dp[i][j]表示以i为节点的子树得到节点数为j的子树最少需要切多少刀。这里不包括父亲节点的部分。
对于每个节点对所有儿子节点跑一下背包即可。
*/




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值