POJ-2533 Longest Ordered Subsequence (线性dp 最长上升子序列)

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 55888 Accepted: 25040

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp[1001], a[1001];
int main(){
	int n, tot;
	scanf("%d", &n);
	for(int i = 1; i <= n; ++i){
		scanf("%d", &a[i]);
	}
	memset(dp, 0, sizeof(dp));
	dp[1] = a[1];
	tot = 1;
	for(int i = 2; i <= n; ++i){
		if(a[i] > dp[tot]){
			dp[++tot] = a[i];
		}
		else{
			int pos = lower_bound(dp + 1, dp + 1 + tot, a[i]) - dp;
			dp[pos] = a[i];
		}
	}
	printf("%d\n", tot);
}

/*
题意:
1000个数,求最长上升子序列。

思路:
线性dp,dp[i]表示长度为i的上升子序列的最后一位的数最小是多少。从左到右扫一遍原数组,维护一下dp值。
最终答案就是tot值,复杂度nlog(n)。
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值