POJ-2479 Maximum sum (线性dp 维护区间最大值 枚举)

Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41882 Accepted: 13068

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input. 
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int dp1[50001], dp2[50001], pre[50001], suf[50001], a[50001];
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		int n;
		scanf("%d", &n);
		for(int i = 1; i <= n; ++i){
			scanf("%d", &a[i]);
		}
		memset(dp1, 0, sizeof(dp1));
		dp1[1] = a[1];
		for(int i = 2; i <= n; ++i){
			dp1[i] = max(dp1[i - 1] + a[i], a[i]);
		}
		dp2[n] = a[n];
		for(int i = n - 1; i >= 1; --i){
			dp2[i] = max(dp2[i + 1] + a[i], a[i]);
		}
		pre[1] = dp1[1];
		for(int i = 2; i <= n; ++i){
			pre[i] = max(pre[i - 1], dp1[i]);
		}
		suf[n] = dp2[n];
		for(int i = n - 1; i >= 1; --i){
			suf[i] = max(suf[i + 1], dp2[i]);
		}
		int ans = -1e9;
		for(int i = n; i >= 2; --i){
			ans = max(ans, suf[i] + pre[i - 1]);
		}
		printf("%d\n", ans);
	}

}

/*
题意:
50000个数,求两段最大连续和,多case,输出最大和。

思路:
如果是一段,那么就是dp[i]表示前i个数且以i为终点的最大连续和。现在要求两段,那么我们正反
各搞一遍dp,然后用pre维护前i个数中最大连续和为多少,suf维护一下i到n中最大连续和为多少,
然后枚举i。
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值