HDU-1058 Humble Numbers(线性dp 枚举因子个数)

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27638    Accepted Submission(s): 12183


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
  
  
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
  
  
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.


#include <bits/stdc++.h>
using namespace std;
int dp[5888];
int main(){
	int n;
	int tot = 0, pos2 = 0, pos3 = 0, pos5 = 0, pos7 = 0, cur;
	dp[0] = 1;
	while(tot < 5843){
		tot++;
		cur = min(min(dp[pos2] * 2, dp[pos3] * 3), min(dp[pos5] * 5, dp[pos7] * 7));
		dp[tot] = cur;
		while(dp[pos2] * 2 <= cur) pos2++;
		while(dp[pos3] * 3 <= cur) pos3++;
		while(dp[pos5] * 5 <= cur) pos5++;
		while(dp[pos7] * 7 <= cur) pos7++;
	}
	while(scanf("%d", &n) != EOF){
		if(n == 0) return 0;
		printf("The ");  
        if(n % 10 == 1 && n % 100 != 11)	printf("%dst", n);  
        else if(n % 10 == 2 && n % 100 != 12)	printf("%dnd", n);  
        else if(n % 10 == 3 && n % 100 != 13)	printf("%drd", n);  
        else	printf("%dth", n);  
        printf(" humble number is %d.\n", dp[n - 1]);  
	}
}

/*
题意:
一个数只包含2,3,5,7素数因子叫做humble number,问第i个humble number是多少。

思路:
根据题意,因为humble number只包含2,3,5,7素数因子,那么枚举2,3,5,7的个数就可以了。
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值