HDU-1789 Doing Homework again (贪心+树状数组+二分)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15472    Accepted Submission(s): 9025


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5



#include <bits/stdc++.h>
using namespace std;
struct point{
	int t, v;
	bool operator < (const point& x) const{
		return v > x.v;
	}
}a[1001];
int c[1001], dl;
inline int lowbit(int x){
	return x & (-x);
}
void add(int x){
	while(x <= dl){
		c[x]++;
		x += lowbit(x);
	}
}
int query(int x){
	int ans = 0;
	while(x){
		ans += c[x];
		x -= lowbit(x);
	}
	return ans;
}
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		int n;
		scanf("%d", &n);
		dl = 0;
		for(int i = 1; i <= n; ++i){
			scanf("%d", &a[i].t);
			dl = max(dl, a[i].t);
		}
		for(int i = 1; i <= n; ++i){
			scanf("%d", &a[i].v);
		}
		sort(a + 1, a + 1 + n);
		memset(c, 0, sizeof(c));
		int ans = 0, l, r, mid;
		for(int i = 1; i <= n; ++i){
			if(query(a[i].t) == a[i].t){
				ans += a[i].v;
			}
			else{
				l = 0;
				r = a[i].t;
				while(r > l){
					mid = l + r >> 1;
					if(query(a[i].t) - query(mid) == a[i].t - mid){
						r = mid;
					}
					else{
						l = mid + 1;
					}
				}
				add(l);
			}
		}
		printf("%d\n", ans);
	}
}

/*
题意:
1000份作业,每天可以做一份作业,每份作业有一个deadline和迟交作业扣的分,问怎么安排作业进度
可以让扣分最少。

思路:
首先,我们一定是先做扣分较大的作业。如果作业当天空闲,那么就当天做,否则就向前查找是否空闲,
如果没有空闲时间,则记录扣分情况。向前查找空闲的操作可以用二分+树状数组将复杂度从O(n)降到O(nlog(n))。
*/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值