POJ-3468 A Simple Problem with Integers (线段树 入门题 区间修改 区间查询)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 122269 Accepted: 37922
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


#include <stdio.h>
using namespace std;
#define maxn 100001
long long c[maxn << 2], lazy[maxn << 2];
void pushdown(int o, int l, int r){
	if(l == r || lazy[o] == 0) return ;
	int mid = l + r >> 1;
	c[o << 1] += lazy[o] * (mid - l + 1);
	c[o << 1 | 1] += lazy[o] * (r - mid);
	lazy[o << 1] += lazy[o];
	lazy[o << 1 | 1] += lazy[o];
	lazy[o] = 0;
}
void build(int o, int l, int r, int id, long long x){
	if(l == r){
		c[o] = x;
		lazy[o] = 0;
		return ;
	}	
	int mid = l + r >> 1;
	if(id <= mid) build(o << 1, l, mid, id, x);
	else build(o << 1 | 1, mid + 1, r, id, x);
	c[o] = c[o << 1] + c[o << 1 | 1];
}
long long query(int o, int l, int r, int L, int R){ 
	pushdown(o, l, r); 
    if(l >= L && r <= R) return c[o];  
    int mid = l + r >> 1;
    long long ans = 0;  
    if(mid >= L) ans += query(o << 1, l, mid, L, R);  
    if(mid < R) ans += query(o << 1 | 1, mid + 1, r, L, R);  
    return ans;  
} 
void add(int o, int l, int r, int L, int R, long long x){
	pushdown(o, l, r);
	if(l >= L && r <= R){
		c[o] += x * (r - l + 1);
		lazy[o] += x;
		return;
	}
	int mid = l + r >> 1;
	if(mid >= L) add(o << 1, l, mid, L, R, x);
	if(mid < R) add(o << 1 | 1, mid + 1, r, L, R, x);
	c[o] = c[o << 1] + c[o << 1 | 1];
}
int main(){
	int n, q, x, l, r;
	scanf("%d %d", &n, &q);
	for(int i = 1; i <= n; ++i){
		scanf("%d", &x);
		build(1, 1, n, i, x);
	}
	char s[4];
	for(int i = 1; i <= q; ++i){
		scanf("%s", s);
		scanf("%d %d", &l, &r);
		if(s[0] == 'Q'){
			printf("%lld\n", query(1, 1, n, l, r));
		}
		else{
			scanf("%d", &x);
			add(1, 1, n, l, r, x);
		}
	}
}

/*
题意:
1e5的数,1e5次操作,每次要么将区间所有数增减v,要么查询区间和。

思路:
线段树区间修改区间查询,入门题。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值