HDU-6186 CS Course (线段树)(2017ACM/ICPC广西邀请赛)

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1134    Accepted Submission(s): 541


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0


#include <stdio.h>
#include <vector>
#include <string.h>
using namespace std;
const int maxn = 100005;
int c1[maxn << 2], c2[maxn << 2], c3[maxn << 2];
void build(int o, int l, int r){
	c1[o] = c2[o] = c3[o] = 0;
	if(l == r) return;
	int mid = l + r >> 1;
	build(o << 1, l, mid);
	build(o << 1 | 1, mid + 1, r);
}
void add(int o, int l, int r, int pos, int x){
	if(l == r){
		c1[o] = c2[o] = c3[o] = x;
		return;
	}
	int mid = l + r >> 1;
	if(pos <= mid){
		add(o << 1, l, mid, pos, x);
	}
	else{
		add(o << 1 | 1, mid + 1, r, pos, x);
	}
	c1[o] = c1[o << 1] & c1[o << 1 | 1];
	c2[o] = c2[o << 1] | c2[o << 1 | 1];
	c3[o] = c3[o << 1] ^ c3[o << 1 | 1];
}
int query(int o, int l, int r, int L, int R, int kind){
	if(l >= L && r <= R){
		if(kind == 1) return c1[o];
		if(kind == 2) return c2[o];
		if(kind == 3) return c3[o];
	}
	int mid = l + r >> 1;
	if(mid >= R) return query(o << 1, l, mid, L, R, kind);
	else if(mid < L) return query(o << 1 | 1, mid + 1, r, L, R, kind);
	else{
		if(kind == 1) return query(o << 1, l, mid, L, R, kind) & query(o << 1 | 1, mid + 1, r, L, R, kind);
		if(kind == 2) return query(o << 1, l, mid, L, R, kind) | query(o << 1 | 1, mid + 1, r, L, R, kind);
		if(kind == 3) return query(o << 1, l, mid, L, R, kind) ^ query(o << 1 | 1, mid + 1, r, L, R, kind);
	}
}
int main(){
	int n, p, x;
	while(scanf("%d %d", &n, &p) != EOF){
		build(1, 1, n);
		for(int i = 1; i <= n; ++i){
			scanf("%d", &x);
			add(1, 1, n, i, x);
		}
		for(int i = 1; i <= p; ++i){
			scanf("%d", &x);
			if(x == 1){
				printf("%d %d %d\n", query(1, 1, n, 2, n, 1), query(1, 1, n, 2, n, 2), query(1, 1, n, 2, n, 3));
			}
			else if(x == n){
				printf("%d %d %d\n", query(1, 1, n, 1, n - 1, 1), query(1, 1, n, 1, n - 1, 2), query(1, 1, n, 1, n - 1, 3));
			}
			else{
				printf("%d %d %d\n", query(1, 1, n, 1, x - 1, 1) & query(1, 1, n, x + 1, n, 1), 
					query(1, 1, n, 1, x - 1, 2) | query(1, 1, n, x + 1, n, 2), 
					query(1, 1, n, 1, x - 1, 3) ^ query(1, 1, n, x + 1, n, 3));
			}
		}
	}
}

/*
题意:
给你1e5个数,1e5次询问,每次询问给出一个数,输出所有数的&,|,^操作和,除了该数。

思路:
线段树裸题。点修改,区间查询。
*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值