POJ-2528 Mayor's posters (离散+线段树 区间修改 区间查询)

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 70791 Accepted: 20416

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4


#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define maxn 10001
int cnt[maxn << 2], l[maxn], r[maxn], c[maxn << 3], ls[maxn << 2];
void pushdown(int o, int l, int r){
	if(l == r || c[o] == -1) return;
	c[o << 1] = c[o];
	c[o << 1 | 1] = c[o];
	c[o] = -1;
}
void add(int o, int l, int r, int L, int R, int v){
	pushdown(o, l, r);
	if(l >= L && r <= R){
		c[o] = v; return;
	}
	int mid = l + r >> 1;
	if(mid >= L) add(o << 1, l, mid, L, R, v);
	if(mid < R) add(o << 1 | 1, mid + 1, r, L, R, v);
}
int query(int o, int l, int r){
	int ans = 0;
	if(c[o] != -1){
		if(cnt[c[o]] == 0){
			ans++;
			cnt[c[o]] = 1;
		}
		return ans;
	}
	if(l == r) return ans;
	int mid = l + r >> 1;
	ans += query(o << 1, l, mid);
	ans += query(o << 1 | 1, mid + 1, r);
	return ans;
}
int main(){
	int T;
	scanf("%d", &T);
	while(T--){
		memset(cnt, 0, sizeof(cnt));
		memset(c, -1, sizeof(c));
		int n, tot = 0, m, num;
		scanf("%d", &n);
		for(int i = 1; i <= n; ++i){
			scanf("%d %d", &l[i], &r[i]);
			ls[++tot] = l[i];
			ls[++tot] = r[i];
		}
		sort(ls + 1, ls + 1 + tot);
		m = num = unique(ls + 1, ls + 1 + tot) - ls;
		for(int i = 1; i < num; ++i){
			if(ls[i] - ls[i - 1] > 1){
				ls[m++] = ls[i - 1] + 1;
			}
		}
		sort(ls + 1, ls + m);
		int x, y;
		for(int i = 1; i <= n; ++i){
			x = lower_bound(ls + 1, ls + m, l[i]) - ls;
			y = lower_bound(ls + 1, ls + m, r[i]) - ls;
			add(1, 1, m, x, y, i);
		}
		printf("%d\n", query(1, 1, m));
	}
}

/*
题意:
1e7的区间,按顺序对不同区间刷不同颜色(自己YY的),问最后整个区间有多少不同颜色。

思路:
线段树区间修改区间查询。需要考虑的是区间长度过大,需要离散化一下,离散的时候一定注意
如果差值大于2的情况不要让它们离散后连续了,比如[1,2],[4,5]很可能离散成[1,2],[3,4],这样会导致答案错误。

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值