Mayor's posters (线段树+离散化+加思维)

 

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

 

题意:给你一个长 10000000 的墙,让你在上面贴海报,输入t,表示有几组数据,下面有一个数字n,表示有n长海报,下面n行,表示每张海报的要贴的区间,从上到下按照顺序贴,看看到最后有几张海报能露出来(露出部分也算)

 

思路:线段树,既是这个区间的懒惰标记值,也就第几张海报,到最后查询一次就行了,只有查询到这个区间的懒惰标记值不为0,就可以返回了,由于给出的墙太长,但是给你的海报上数就10000,所以你可以离散化;

代码一:离散化时,搞错了,但poj上能过,数据太水了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 10010

struct node
{
	int x,y;
}s[Max];
int stu[8*Max];
int n;
int book[Max];
int a[2*Max];
void build(int root,int star,int end)
{
	stu[root] = 0;
	if(star==end)
		return ;
	int mid = (star+end)/2;
	build(root*2,star,mid);
	build(root*2+1,mid+1,end);
}

void down(int root)
{
	stu[2*root] = stu[2*root+1] = stu[root];
	stu[root] = 0;
}
void updat(int root,int star,int end,int x,int y,int val)
{
	if(star>=x&&end<=y)
	{
		stu[root] = val;
		return ;
	}
	if(stu[root])
		down(root);
	int mid = (star+end)/2;
	if(x<=mid)
		updat(root*2,star,mid,x,y,val);
	if(y>mid) updat(root*2+1,mid+1,end,x,y,val);
}

void Qury(int root,int star,int end)
{
	if(star==end&&stu[root]==0)
		return ;
	if(stu[root])
	{
		book[stu[root]] = 1;
		return ;
	}
	int mid = (star+end)/2;
	Qury(root*2,star,mid);
	Qury(root*2+1,mid+1,end);
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		int x,y;
		scanf("%d",&n);
		memset(book,0,sizeof(book));
		int ma = 0;
		int tt = 0;
		for(i = 1;i<=n;i++)
		{
			scanf("%d%d",&s[i].x,&s[i].y);
			a[tt++] = s[i].x;
			a[tt++] = s[i].y;	
		}
		sort(a,a+tt);
		for(i = 1;i<=n;i++)
		{
			s[i].x = (lower_bound(a,a+tt,s[i].x)-a) + 1;
			s[i].y = (lower_bound(a,a+tt,s[i].y)-a) + 1;
		}
		build(1,1,tt);
		for(i = 1;i<=n;i++)
			updat(1,1,tt,s[i].x,s[i].y,i);
		Qury(1,1,tt);
		int sum = 0;
		for(i = 1;i<=n;i++)
			if(book[i])
				sum++;
		printf("%d\n",sum);
	}
	return 0;
} 

修改后的代码:

#include<stdio.h>
#include<algorithm>
#include<vector>
#include<string.h>
using namespace std;
#define Max 20010
vector<int> v;
struct node
{
	int x,y;
}s[Max];
int stu[10*Max];
int n;
int book[Max];
int a[Max];
void build(int root,int star,int end)
{
	stu[root] = 0;
	if(star==end)
		return ;
	int mid = (star+end)/2;
	build(root*2,star,mid);
	build(root*2+1,mid+1,end);
}
 
void down(int root)
{
	stu[2*root] = stu[2*root+1] = stu[root];
	stu[root] = 0;
}
void updat(int root,int star,int end,int x,int y,int val)
{
	if(star>=x&&end<=y)
	{
		stu[root] = val;
		return ;
	}
	if(stu[root])
		down(root);
	int mid = (star+end)/2;
	if(x<=mid)
		updat(root*2,star,mid,x,y,val);
	if(y>mid) 
	updat(root*2+1,mid+1,end,x,y,val);
}
 
void Qury(int root,int star,int end)
{
	if(star==end&&stu[root]==0)
		return ;
	if(stu[root])
	{
		book[stu[root]] = 1;
		return ;
	}
	int mid = (star+end)/2;
	Qury(root*2,star,mid);
	Qury(root*2+1,mid+1,end);
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		v.clear();
		int x,y;
		scanf("%d",&n);
		memset(book,0,sizeof(book));
		int ma = 0;
		int tt = 0;
		for(i = 1;i<=n;i++)
		{
			scanf("%d%d",&s[i].x,&s[i].y);
			v.push_back(s[i].x);
			v.push_back(s[i].y);
		}
		sort(v.begin(),v.end());
		v.erase(unique(v.begin(),v.end()),v.end()); // 去掉重复元素;
		a[0] = 1;
		int kk = 1; 
        // 离散化时,相邻的元素还让它们相邻,不相邻的元素之间相差2,不让它们相邻
		for(int i = 1;i<v.size();i++)
		{
			if(v[i] ==v[i-1] + 1){
				kk ++;
				a[i] = kk;
			}
			else{
				kk +=2;
				a[i] = kk;
			}			
		}		
		for(i = 1;i<=n;i++){
			s[i].x = a[(lower_bound(v.begin(),v.end(),s[i].x)-v.begin())];
			s[i].y = a[(lower_bound(v.begin(),v.end(),s[i].y)-v.begin())];
			//printf("s[%d].x==%d  %d\n",i,s[i].x,s[i].y) 
		}		
		build(1,1,v.size()*2+10);
		for(i = 1;i<=n;i++)
			updat(1,1,v.size()*2+10,s[i].x,s[i].y,i);
		Qury(1,1,v.size()*2+10);
		int sum = 0;
		for(i = 1;i<=n;i++)
			if(book[i])
				sum++;
		printf("%d\n",sum);
	}
	return 0;
} 

 

  • 4
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 8
    评论
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值