poj 3628 Bookshelf 2 01背包

Bookshelf 2
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7167 Accepted: 3298

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ BS, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

====================================================================================

题目大意:说一群奶牛一个叠一个想够到书架的顶(我也想吐槽这个设定),已知每头牛高度和书架高度,牛梯不能低于书架高度,求牛梯最少超过书架顶多少。


解题思路:设牛梯最高高度为sum,即奶牛身高和为sum,则令背包容量为 v = sum - b 。

也就是说先默认使用所有的奶牛,再去掉尽量多的奶牛高度,使牛梯不低于b 。

则答案为 v - 去掉的奶牛高度和。

看下时间复杂度,dp状态表横轴 v <= 20*1000,000,纵轴不大于20,O(4*10^8),感觉比较边缘,不过这么明显的01背包应该是能行的。

空间复杂度4*10^8个int,1600M有点吓人,滚动数组160M,还是超。。。。。我没办法了。

可是ac了,还是0ms,还是700+KB的内存占用,数据好弱。政哥嫌麻烦写了个深搜32ms过的。

我就不试深搜了。

//Memory: 776K	Time: 0MS

#include<cstdio>
#include<algorithm>
using namespace std;

int cow[21], dp[2][20000000];

int main()
{
    int n, b, sum = 0;
    scanf("%d%d", &n, &b);
    for( int i = 1 ; i <= n ; i++ )
    {
        scanf("%d", &cow[i]);
        sum += cow[i];
    }
    int v = sum-b;
    for( int i = 1 ; i <= n ; i++ )
        for( int j = 1 ; j <= v ; j++ )
            if(j < cow[i])
                dp[i&1][j] = dp[(i-1)&1][j];
            else
                dp[i&1][j] = max(dp[(i-1)&1][j],dp[(i-1)&1][j-cow[i]]+cow[i]);
    printf("%d\n", v-dp[n&1][v]);
    return 0;
}
不用滚动数组3500+KB,32ms也能过。不过据政哥说,用c++编译器会报MLE,g++就没事。

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值