HDU--杭电--2303--The Embarrassed Cryptographer--暴力爆菊花

The Embarrassed Cryptographer

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 458    Accepted Submission(s): 141


Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.
 

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
 

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
 

Sample Input
  
  
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0
 

Sample Output
  
  
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31


题意就是给你一个超级大的数a和一个100W一下的数b,求a所有素数因子中最小的是否大于b,有就输出bad加上这个素数,不然就输出good

#include <iostream>
#include <cstdio>
using namespace std;
int main (void)
{
    int n,s,ss[100000],i,j,k,l;
    char str[111];
    for(i=2,l=0;i<=1000003;i++)	//弄个素数表
    {
        for(j=2;j*j<=i;j++)
        if(i%j==0){j=0;break;}
        if(j)ss[l++]=i;
    }
    while(scanf("%s%d",str,&n)!=EOF&&(str[0]-48||n))
    {
        for(i=0;i<l&&ss[i]<n;i++)	//从第一个素数开始到小于n的最后一个素数
        {
            for(j=s=0;str[j];j++)	//直接暴力求解,从首位一位一位向后拿出来除
            {
                s=s*10+str[j]-48;
                s%=ss[i];	//除了之后带上余数继续向后除
            }
            if(s==0)break;	//出现了最小的那个就跳出
        }
        if(ss[i]<n)printf("BAD %d\n",ss[i]);	//判断跳出并输出相应的
        else puts("GOOD");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值