HDU 2303 The Embarrassed Cryptographer(素数筛选+同余定理)

18 篇文章 0 订阅
11 篇文章 0 订阅

The Embarrassed Cryptographer

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 783    Accepted Submission(s): 245

Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
Sample Input
  
  
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0

Sample Output
  
  
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31

Source
Recommend
zty   |   We have carefully selected several similar problems for you:  2300 2308 2301 2305 2306 

题意:给你两个数s,k; 让你求s的最小素因子是否小于k。

题解:
高精度求模+同余模定理。

素数筛选要筛选打表到100W 以上(题目要求10^6)。
根据同余定理, X*Y%mod==(X%mod*Y%mod)%mod
可以将K分解再取mod。

AC代码:
#include<bits/stdc++.h> 
using namespace std;
const int INF = 999999;
int prime[1000003],prim[333334];
char s[234];
int main()
{
   
    int k,num=0;
    memset(prime,0,sizeof(prime));
    for(int i=2; i<=1000000; i++){
        if(prime[i]==0){
            prim[num++]=i;
            for(int j=i*2; j<=1000000; j+=i)
                prime[j]=1;
        }
    }
    while(scanf("%s %d",s,&k))
    {
        if(k==0&&s[0]=='0') break;
        int len=strlen(s);
        int sum=0,minn=10000003,i;
        for( i=0;i<num; i++)
        {
            sum=0;
            for( int j=0;j<len;j++)
                sum=(sum*10+(s[j]-'0'))%prim[i];//mod
            if(sum==0)
                break;
        }
        if(i!=num&&prim[i]<k)
        {
        	printf("BAD %d\n",prim[i]);
		}
        else printf("GOOD\n");
    }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值