The Embarrassed Cryptographer+质数表

74 篇文章 1 订阅
2 篇文章 0 订阅

The Embarrassed Cryptographer

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 383    Accepted Submission(s): 113


Problem Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.
 

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10 100 and 2 <= L <= 10 6. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.
 

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.
 

Sample Input
  
  
143 10 143 20 667 20 667 30 2573 30 2573 40 0 0
 

Sample Output
  
  
GOOD BAD 11 GOOD BAD 23 GOOD BAD 31
 
/*
思路:打质数表求解,打1000000内的所有质数的表,然后用a[]
整除小于b的所有质数,思路很简单,一定要打表,不然超时
*/

#include<iostream>
#include<stdlib.h>
#include<cmath>
using namespace std;

#define N  1000000
int sieve[N + 1];
int prime[N+1],k=0;

//质数表
void Cprime(){
  int i;
  for( i = 2; i <= N; i++) sieve[i] = 1;
  for(i = 2; i <= N / 2; i++) sieve[i * 2] = 0; 
  int p = 2;
  while(p * p <= N)
  {
    p = p + 1;
   while(sieve[p] == 0)
    p++;
   int t = p * p;
   int s = 2 * p;
   while(t <= N)
   {
     sieve[t] = 0;
    t = t + s;
   }
  }
 for(i=2;i<=N;i++)
  if(sieve[i]!=0)
   prime[k++]=i;
  return ;
}

int main()
{
	char a[102];
	int b;
	Cprime();
	while(cin>>a>>b&&(strcmp(a,"0")||b!=0)){
		int i,len=strlen(a),flag=0;
		for(i=0;i<k;i++){
			if(prime[i]>=b){
				flag=1;
				break;
			}
			int sum=0;
			for(int j=0;j<len;j++){
				sum=sum*10+a[j]-'0';
				if(sum>=prime[i])
					sum%=prime[i];
			}
			sum%=prime[i];
			if(sum==0)
				break;
		}
		if(i>=k||flag)
			cout<<"GOOD"<<endl;
		else
			cout<<"BAD "<<prime[i]<<endl;
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值