Strange fuction
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2494 Accepted Submission(s): 1869
Problem Description
Now, here is a fuction:
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2 100 200
Sample Output
-74.4291 -178.8534
重点:定义域是实数
在草稿上推算得到函数在定义域内呈开口向上的曲线,所以直接求导然后求出极值点
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
double h(double x) //原函数式
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2);
}
double h1(double x) //导函数式
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main (void)
{
int n;
double l,r,x,y;
scanf("%d",&n);
while(n--&&scanf("%lf",&y))
{
l=0;r=100; //取定义域的两端
while(r-l>1e-7) //进行二分查找
{
x=(l+r)/2;
if(h1(x)<y)l=x+1e-7;
else r=x-1e-7;
}
printf("%.4lf\n",h(x)-x*y);
}
return 0;
}