POJ--3181--Dollar Dayz--背包/高精度

21 篇文章 0 订阅

Dollar Dayz
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4220 Accepted: 1642

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 

        1 @ US$3 + 1 @ US$2

        1 @ US$3 + 2 @ US$1

        1 @ US$2 + 3 @ US$1

        2 @ US$2 + 1 @ US$1

        5 @ US$1
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

题意:输入n,k表示有k种硬币,价值是1~k,求用这些硬币组合出价值n的方案数

解析:数值很大,64位装不下,所以用两个64位的分别充当高位和低位来解决,然后就是完全背包问题了

*******这里有个点我要说,虽然不算错,但是这是题目的漏洞跟思维的严谨,就是当有高位需要输出时一定要把位补起来,一般都是以1E18为摸,所以一般都是有高位就输出高位,接着把低位输出,我说如果低位没有18位整的呢?

拿100来说,高位是1,低位是99,这好,输出来直接就是199,如果低位是9呢?输出的就是19,低位的前导零没有处理啊,有些代码的正确只是建立在数据的不严谨啊。。


#include <iostream>
#include <cstdio>
#include <cstring>
#define Max(a,b) a>b?a:b
using namespace std;
__int64 mod=1000000000000000000;
int main (void)
{
    int n,m,i,j,k,l;
    __int64 dp[2][1111];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        if(m>n)m=n;
        for(i=1;i<=m;i++)
        for(j=i;j<=n;j++)
        {
            dp[1][j]=dp[1][j-i]+dp[1][j]+(dp[0][j-i]+dp[0][j])/mod;	//高位
            dp[0][j]=(dp[0][j-i]+dp[0][j])%mod;	//低位
        }
        if(dp[1][n])
        {
            printf("%I64d",dp[1][n]);
            printf("%018I64d\n",dp[0][n]);	//补充前导零
        }else
        {
            printf("%I64d\n",dp[0][n]);	//这个不用补充前导零
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值