HDU--杭电--1518--Square--深搜--要剪枝

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5771    Accepted Submission(s): 1836


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 


 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 


 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 


 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 


 

Sample Output
  
  
yes no yes

 

#include <iostream>
#include <algorithm>
using namespace
std;
int
n,s,k,a[22],visit[22]={0};
void
DFS(int sum,int x,int d)
{

    if
(
k||x==3)  //匹配好了三个边就行了,用k标记,并剪枝
    {

        k=1;return;
    }

    int
i;
    for
(
i=d;i<n;i++)  //从d开始,起到剪枝作用,同时避免1-2-3和1-3-2这种重复
    {

        if
(
k)return;  //把k插入,剪枝
        if
(!
visit[i])
        if
(
sum+a[i]==s)  //加上这个长度后正好是一个边
        {

            visit[i]=1;
            DFS(0,x+1,0);
            visit[i]=0;
        }

        else if
(
sum+a[i]<s)  //加上这个长度后还不够形成一个边
        {

            visit[i]=1;
            DFS(sum+a[i],x,i+1);
            visit[i]=0;
        }
    }
}

bool
cmp(int a,int b)
{

    return
a<b;
}

int
main(void)
{

    int
m,i;
    cin>>m;
    while
(
m--&&cin>>n)
    {

        for
(
i=s=0;i<n;i++)
            cin>>a[i],s+=a[i];
        sort(a,a+n,cmp);
        if
(
s%4==0)
        {

            s/=4;
            k=0;
            DFS(0,0,0);  //里面的三个0分别是指当前合成的长度,当前已配好的边数,当前询问到的地点
            if
(
k)cout<<"yes"<<endl;
            else
cout<<"no"<<endl;
        }

        else
cout<<"no"<<endl;
    }

    return
0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值