杭电1518 Square(DFS+剪枝)

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8940    Accepted Submission(s): 2908


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
/*
这个思路不错,加油!!!传入四个变量,搜索到一个就将个数加1,其余置0,再搜索。加油!!!
Time:2014-11-9 18:40

*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAX 22
struct Stick{
	int len;
	bool vis;
}stick[MAX];
int n;
bool cmp(Stick a,Stick b){
	return a.len>b.len;
}
bool DFS(int tarlen,int curlen,int cnt,int pos){
	if(cnt==4)  return true;
	for(int i=pos;i<n;i++){
		if(stick[i].vis)
			continue;//如果用过
		if(curlen+stick[i].len==tarlen){
			stick[i].vis=true;
			//cnt++;
			if(DFS(tarlen,0,cnt+1,0)) return true;//数量加1 从0开始搜索 
			stick[i].vis=false;
			//cnt--;
		}else if(tarlen>(curlen+stick[i].len)){//回溯 
			curlen+=stick[i].len;
			stick[i].vis=true;
			if(DFS(tarlen,curlen,cnt,i+1)) return true;
			curlen-=stick[i].len; 
			stick[i].vis=false;
		} 
	}
	return false;
} 
int main(){
	int T;
	int tarlen;
	scanf("%d",&T);
	while(T--){
		scanf("%d",&n); tarlen=0;
		for(int i=0;i<n;i++){
			scanf("%d",&stick[i].len);
			stick[i].vis=false;
			tarlen+=stick[i].len;
		}
		if(tarlen%4!=0||n<4){
			printf("no\n");
			continue;
		}
		sort(stick,stick+n,cmp);
		tarlen/=4;
		if(stick[0].len>tarlen){
			printf("no\n");
			continue;
		}
		if(DFS(tarlen,0,0,0)){//分别为目标长度、次数,现有长度, 
			printf("yes\n");
		}else{
			printf("no\n");
		}
	}
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值