杭电1398-Square Coins

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6624    Accepted Submission(s): 4473


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 

Sample Input
  
  
2 10 30 0
 

Sample Output
  
  
1 4 27
AC代码+详细解释:
#include<iostream>//母函数做法,排列组合加法对应指数幂乘法
#include<cstdio>
#include<cstring>
const int MAX=301;
int c1[MAX];//c1[2]=1代表价值2的支付金额只有一种方式来付即文中two 1-credit coins仅此一种,同理c1[n]=m代表价值为n的支付金额可以有m种付法
int c2[MAX];//中间变量
int n;
using namespace std;
int main()
{
    int i,j;
    while(cin>>n,n)
    {
        for(i=0;i<=n;i++)
        {
            c1[i]=1;
            c2[i]=0;
        }
        for(i=2;i<=17;++i)//一共有多少种硬币
        {
            for(j=0;j<=n;j++)//这里j是指数即与之相乘的指数
            {
                for(int k=0;k+j<=n;k+=i*i)//k+j代表相乘后指数相加
                {
                    c2[j+k]+=c1[j];
                }
            }
            for(j=0;j<=n;j++)
            {
                c1[j]=c2[j];//把过渡量再赋值给c1
                c2[j]=0;//再初始化为0
            }
        }
        cout<<c1[n]<<endl;
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值