hdu 3172 Virtual Friends (map+并查集)

Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person’s network.

Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.

Input
Input file contains multiple test cases. The first line of each case indicates the number of test friendship nest. each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input
1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output
2
3
4

题意:有多个测试组T,每个测试组第一行n,接下来n行表示甲与乙认识,每给出一个关系,求出两人总共认识的人,包括本身;
思路:简单并查集+map的使用;
代码:

#include<cstdio>
#include<map>
#include<algorithm>
#include<iostream>
using namespace std;
int a[200000],vag[200000];
map<string,int>m;
int find(int t)
{
    if(t!=a[t])
        a[t]=find(a[t]);
    return a[t];
}
void mark(int x,int y)
{
    int zx=find(x);
    int zy=find(y);
    if(zx==zy)
    {
        printf("%d\n",vag[zx]);
        return;
    }
    else
        printf("%d\n",vag[zx]+vag[zy]);
    if(vag[zx]<vag[zy])
    {
        a[zx]=zy;
        vag[zy]+=vag[zx];
        vag[zx]=0;
    }
    else
    {
        a[zy]=zx;
        vag[zx]+=vag[zy];
        vag[zy]=0;
    }
}
int main()
{
    int T;
    while(~scanf("%d",&T))
    {while(T--)
    {
        char c1[50],c2[50];
        int n;
        scanf("%d",&n);
        for(int i=1;i<=2*n;i++)
        {
            a[i]=i;
            vag[i]=1;
        }
        int ans=1;
        m.clear();
        while(n--)
        {
            scanf("%s%s",c1,c2);
            if(!m[c1])
            {
                m[c1]=ans++;
            }
            if(!m[c2])
            {
                m[c2]=ans++;
            }
            mark(m[c1],m[c2]);
        }
    }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值