hdu 1845 Jimmy’s Assignment (二分匹配)

Problem Description

Jimmy is studying Advanced Graph Algorithms at his university. His most recent assignment is to find a maximum matching in a special kind of graph. This graph is undirected, has N vertices and each vertex has degree 3. Furthermore, the graph is 2-edge-connected (that is, at least 2 edges need to be removed in order to make the graph disconnected). A matching is a subset of the graph’s edges, such that no two edges in the subset have a common vertex. A maximum matching is a matching having the maximum cardinality.
  Given a series of instances of the special graph mentioned above, find the cardinality of a maximum matching for each instance.

Input

The first line of input contains an integer number T, representing the number of graph descriptions to follow. Each description contains on the first line an even integer number N (4<=N<=5000), representing the number of vertices. Each of the next 3*N/2 lines contains two integers A and B, separated by one blank, denoting that there is an edge between vertex A and vertex B. The vertices are numbered from 1 to N. No edge may appear twice in the input.

Output

For each of the T graphs, in the order given in the input, print one line containing the cardinality of a maximum matching.

Sample Input

2
4
1 2
1 3
1 4
2 3
2 4
3 4
4
1 2
1 3
1 4
2 3
2 4
3 4

Sample Output

2
2



题意:求最大匹配的边数,每个顶点最多只能用一次。

思路:用邻接表存数据,然后二分匹配,由于是双向建图,所以得出的结果要除以2;

注意:很卡时间,while 比 for 循环快,所以尽可能的用while ;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=5005;
struct node{
    int now,next;
}str[N*3];
int n,len;
int head[N],vis[N],link[N];
void add(int a,int b)
{
    str[len].now=b;
    str[len].next=head[a];
    head[a]=len++;
}
int find(int u)
{
    for(int i=head[u];i!=-1;i=str[i].next)
    {
        int v=str[i].now;
        if(!vis[v])
        {
            vis[v]=1;
            if(!link[v]||find(link[v]))
            {
                link[v]=u;
                return 1;
            }
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(head,-1,sizeof(head));
        memset(link,0,sizeof(link));
        int k=(3*n)/2;
        len=0;
        while(k--)  //这里必须用while,不然会超时;
        {
            int a,b;
            scanf("%d%d",&a,&b);
            add(a,b);
            add(b,a);
        }
        int s=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            s+=find(i);
        }
        printf("%d\n",s/2);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值