poj 2955 Brackets (区间DP)

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end
Sample Output

6
6
4
0
6
题意:在一些括号中找到一个序列,里面的括号都两两配对。求序列最长长度。 有点注意,比如 (])] 输出为2,说不清,自己看这个列子会更加理解题意。
思路:区间DP,定义dp [ i ] [ j ] 为串中第 i 个到第 j 个括号的最大匹配数目
那么我们假如知道了 i 到 j 区间的最大匹配,那么i+1到 j+1区间的是不是就可以很简单的得到。
那么 假如第 i 个和第 j 个是一对匹配的括号那么 dp [ i ] [ j ] = dp [ i+1 ] [ j-1 ] + 2 ;
那么我们只需要从小到大枚举所有 i 和 j 中间的括号数目,然后满足匹配就用上面式子dp,然后每次更新dp [ i ] [ j ]为最大值即可。
更新最大值的方法是枚举 i 和 j 的中间值,然后让 dp[ i ] [ j ] = max ( dp [ i ] [ j ] , dp [ i ] [ f ] + dp [ f+1 ] [ j ] ) 。
代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int find(char x,char y)
{
    if(x=='('&&y==')')
        return 2;
    else if(x=='['&&y==']')
        return 2;
    else
        return 0;
}
int main()
{
    char c[101];
    int dp[101][101];
    while(~scanf("%s",c))
    {
        memset(dp,0,sizeof(dp));
        if(strcmp(c,"end")==0)
            break;
        int len=strlen(c);
        for(int i=0;i<len-1;i++)
        {
            dp[i][i+1]=find(c[i],c[i+1]);
        }
        for(int k=2;k<len;k++)
        {
            for(int i=0;i+k<len;i++)
            {
                if(find(c[i],c[i+k]))
                    dp[i][i+k]=dp[i+1][i+k-1]+2;
                for(int j=i;j<i+k;j++)
                   dp[i][i+k]=max(dp[i][i+k],dp[i][j]+dp[j+1][i+k]);
            }
        }
        printf("%d\n",dp[0][len-1]);
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值