hdu 2196 Computer (树形DP)

Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information.


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
   
   
3 2 3 4 4
 
题意: 给出每台电脑到某台电脑的距离,求出每台电脑所能到达的最长距离,根节点规定为1;
思路: 

把无根树转化成有根树分析,

对于上面那棵树,要求距结点2的最长距离,那么,就需要知道以2为顶点的子树(蓝色圈起的部分,我们叫它Tree(2)),距顶点2的最远距离L1

还有知道2的父节点1为根节点的树Tree(1)-Tree(2)部分(即红色圈起部分),距离结点1的最长距离+dist(1,2) = L2,那么最终距离结点2最远的距离就是max{L1,L2}

dp[i][0],表示顶点为i的子树的,距顶点i的最长距离;

dp[i][1]表示顶点为i的子树的,距顶点i的次大距离;

要求所有的dp[i][0]和dp[i][1]很简单,只要先做一次dfs求每个结点到叶子结点的最长距离即可。

dfs1是更新节点dp[i][0]和dp[i][1],详解如下:
假设节点u有n个子节点,分别是v1,v2...vn
那么
如果vi不是u最长距离经过的节点,dp[vi][1] = max(dist(vi,u)+dp[u][0],dp[vi][1]);dp[0]=max(dp[0],dp[1]);
如果vi是u最长距离经过的节点,那么不能选择dp[u][0],因为这保存的就是最长距离,要选择Tree(u)第二大距离dp[u][1],
可得dp[vi][1] = max(dist(vi,u)+dp[u][1],dp[vi][1]);dp[0]=max(dp[0],dp[1]);

代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int dp[10005][2],head[10005],mag1[10005],mag0[10005]; //mag1表示次大距离的子节点,<span style="font-family: Arial;">mag0表示最大距离的子节点</span>
int n,len;
struct node{
   int now,next,w;
}str[20005];
void add(int x,int y,int wi) //双向建树;
{
    str[len].now=x;
    str[len].next=head[y];
    str[len].w=wi;
    head[y]=len++;
    str[len].now=y;
    str[len].next=head[x];
    str[len].w=wi;
    head[x]=len++;
}
void dfs(int root,int p) 
{
    for(int i=head[root];i!=-1;i=str[i].next)
    {
        int k=str[i].now;
        if(k==p)  
           continue;
        dfs(k,root);
        if(dp[root][1]<dp[k][0]+str[i].w)
        {
            dp[root][1]=dp[k][0]+str[i].w;
            mag1[root]=k;
            if(dp[root][1]>dp[root][0])
            {
                swap(dp[root][1],dp[root][0]);
                swap(mag0[root],mag1[root]);
            }
        }
    }
}
void dfs1(int root,int p)
{
    for(int i=head[root];i!=-1;i=str[i].next)
    {
        int k=str[i].now;
        if(k==p)
           continue;
        if(k!=mag0[root])
        {

            if(dp[root][0]+str[i].w>dp[k][1])
            {
                dp[k][1]=dp[root][0]+str[i].w;
                mag1[k]=root;
                if(dp[k][1]>dp[k][0])
                {
                    swap(dp[k][1],dp[k][0]);
                    swap(mag0[k],mag1[k]);
                }
            }
        }
        else
        {
            if(dp[root][1]+str[i].w>dp[k][1])
            {
                dp[k][1]=dp[root][1]+str[i].w;
                mag1[k]=root;
                if(dp[k][1]>dp[k][0])
                {
                    swap(dp[k][1],dp[k][0]);
                    swap(mag0[k],mag1[k]);
                }
            }
        }
        dfs1(k,root);
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        len=0;
        memset(head,-1,sizeof(head));
        memset(dp,0,sizeof(dp));
        memset(mag0,0,sizeof(mag0));
        memset(str,-1,sizeof(str));
        memset(mag1,0,sizeof(mag1));
        for(int i=2;i<=n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            add(i,x,y);
        }
        dfs(1,-1);
        dfs1(1,-1);
        for(int i=1;i<=n;i++)
        printf("%d\n",dp[i][0]);
    }
}





Sample Output
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值