poj 3254 Corn Fields (状态DP)

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

USACO 2006 November Gold


题意:在一个n*m的棋盘里放棋子,其中哪些位置可以放哪些位置不可以放已知,并且要求在放棋子的时候上下左右不能有棋子相邻。求一共有多少种方法可以完成该任务。

简单状态DP;

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
const int mod=100000000;
int map[15][15],a[1<<14],vis[1<<14];
int dp[15][1<<14];
int find(int i,int x)
{
    if(a[i]&vis[x])
        return 0;
    else
        return 1;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(a,0,sizeof(a));
        for(int i=0;i<n;i++)
        {
            int s=0;
            for(int j=0;j<m;j++)
            {
                scanf("%d",&map[i][j]);
                if(!map[i][j])
                    s=s|(1<<j);
            }
            a[i]=s;
        }
        int ans=0;
        for(int i=0;i<(1<<m);i++)
            if(!(i&(i<<1)))
            {
                vis[ans++]=i;
            }
        for(int i=0;i<ans;i++)
            if(find(0,i))
            {
                dp[0][vis[i]]=1;
            }
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<ans;j++)
            {
                if(!find(i,j))
                    continue;
                for(int k=0;k<ans;k++)
                {
                    if(find(i-1,k)&&!(vis[j]&vis[k]))
                        dp[i][vis[j]]=(dp[i][vis[j]]+dp[i-1][vis[k]])%mod;
                }
            }
        }
        int sum=0;
        for(int i=0;i<ans;i++)
            sum=(sum+dp[n-1][vis[i]])%mod;
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值